Bug 204173 - openoffice crashes in cjk locale.
openoffice crashes in cjk locale.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
: 204282 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 07:51 EDT by sangu
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.4-2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 10:07:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-08-26 07:51:02 EDT
Description of problem:
in LANG=ko_KR.UTF-8
$ oowriter 
---start copy and paste here---
(I) x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(III) Desktop is: GNOME
(IV) libgcj version is: libgcj-4.1.1-19-i386
(V) kernel is: Linux 2.6.17-1.2586.fc6 #1 SMP Thu Aug 24 08:51:22 EDT 2006 i686
athlon i386
(VI) OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-2.1-i386
(VII) accessibility is: false
(VIII) fedora release is: Fedora Core release 5.91 (FC6 Test2)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x18e92dc: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x202dc
0x18e9b11: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x20b11
0xb7f6b420:  + 0x420 (__kernel_sigreturn + 0x0)
0x372888f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10d88f
0x37288c4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10d8c4
0x371cc6b: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x101c6b
0x371d007: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x102007
0x371d519: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x102519
0x371e535: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x103535
(OutputDevice::GetTextArray(String const&, long*, unsigned short, unsigned
short) const + 0x6f)
0x371e61a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10361a
(OutputDevice::GetTextWidth(String const&, unsigned short, unsigned short) const
+ 0x26)
0x371e690: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x103690
(OutputDevice::GetCtrlTextWidth(String const&, unsigned short, unsigned short,
unsigned short) const + 0x70)
0x37bba73: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1a0a73
0x37c219c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1a719c
0x37c3c68: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1a8c68
(PopupMenu::Execute(Window*, Rectangle const&, unsigned short) + 0x42)
0x37c3ca5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1a8ca5
(PopupMenu::Execute(Window*, Point const&) + 0x37)
0x20a55c6: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1bd5c6
0x20a6127: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1be127
0x2088f55: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a0f55
(SfxDispatcher::ExecutePopup(unsigned short, Window*, Point const*) + 0xdd)
0x6ef5be: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x5de5be
0x38027cc: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1e77cc
0x3804812: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1e9812
0x3805da3: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1eada3
0x3804b08: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1e9b08
0x2a389f0: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x319f0
0x2a368c8: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x2f8c8
0x252edb0: /usr/lib/libgtk-x11-2.0.so.0 + 0x130db0
0x280bf0b: /lib/libgobject-2.0.so.0 + 0x8f0b (g_closure_invoke + 0x12b)
0x281cd63: /lib/libgobject-2.0.so.0 + 0x19d63
0x281e027: /lib/libgobject-2.0.so.0 + 0x1b027 (g_signal_emit_valist + 0x667)
0x281e419: /lib/libgobject-2.0.so.0 + 0x1b419 (g_signal_emit + 0x29)
0x2642448: /usr/lib/libgtk-x11-2.0.so.0 + 0x244448
0x2528253: /usr/lib/libgtk-x11-2.0.so.0 + 0x12a253 (gtk_propagate_event + 0x183)
0x2529457: /usr/lib/libgtk-x11-2.0.so.0 + 0x12b457 (gtk_main_do_event + 0x317)
0x61471aa: /usr/lib/libgdk-x11-2.0.so.0 + 0x411aa
0x61ec372: /lib/libglib-2.0.so.0 + 0x2b372 (g_main_context_dispatch + 0x182)
0x61ef34f: /lib/libglib-2.0.so.0 + 0x2e34f
0x61ef8b5: /lib/libglib-2.0.so.0 + 0x2e8b5 (g_main_context_iteration + 0x65)
0x2a1a19a: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1319a
0x67d296e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x4596e
(X11SalInstance::Yield(bool, bool) + 0x2c)
0x36a53ff: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a3ff
(Application::Yield(bool) + 0x53)
0x36a5494: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a494
(Application::Execute() + 0x28)
0xfa9186: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x23186
(desktop::Desktop::Main() + 0x164e)
0x36a92a2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e2a2
0x36a9365: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e365 (SVMain()
+ 0x2b)
0xfa2d09: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cd09 (sal_main +
0x5d)
0xfa2d55: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cd55 (main + 0x27)
0xa4b24c: /lib/libc.so.6 + 0x1924c (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4a1
---end copy and paste here---
paste the above into your bug report

but After operating this commands, this problem disappear.
$rpm -e  openoffice.org-langpack-ko_KR-2.0.4-2.1
$rm -rf .openoffice.org2.0/

Version-Release number of selected component (if applicable):
2.0.4-2.1

How reproducible:
always

Steps to Reproduce:
1. $yum install openoffice.org-langpack-ko_KR-2.0.4-2.1
2. $ LANG=ko_KR.UTF-8 oowriter
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Damien Durand 2006-08-26 07:53:54 EDT
Thank you for taking the time to report this bug. This bug report isn't very
useful because it doesn't describe the bug well. If you have time and can
still reproduce the bug, please read 
http://fedoraproject.org/wiki/BugsAndFeatureRequests and add a more useful 
description to this bug.
Thank you.
Comment 2 sangu 2006-08-26 08:01:30 EDT
When installing korean lanpack(openoffice.org-langpack-ko_KR-2.0.4-2.1),
openoffice 2.0.4-2.1 crashes in locale ko_KR.UTF-8.
Comment 3 Damien Durand 2006-08-26 08:08:14 EDT
Ha ok, sorry for this, but for me the description was not complete. 
Comment 4 Caolan McNamara 2006-08-26 11:31:32 EDT
Does this *always* happen, I've this installed here and I don't see this problem, 

though I note...

/usr/lib/xorg/modules/drivers/nvidia_drv.so

which is the nvidia driver isn't it ? 

Could you perhaps try with the xorg nv driver just for testing purposes to
verify that it happens then as well
Comment 5 sangu 2006-08-26 23:15:42 EDT
this problem doesn't happen in openoffice.org 2.0.3-7.9

locale LANG=ko_KR.UTF-8, Installed ko_KR langpack. 
When clicking a menu or button with mouse on openoffice.org, the bug happens.

openoffice.org 2.0.4-2.1 backtrace file

$ gdb /usr/lib/openoffice.org2.0/program/soffice.bin 
GNU gdb Red Hat Linux (6.5-5.fc6rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(gdb) r
Starting program: /usr/lib/openoffice.org2.0/program/soffice.bin 
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1218315696 (LWP 4947)]
warning: Lowest section in /usr/lib/libicudata.so.36 is .gnu.hash at 000000b4
[New Thread -1218450544 (LWP 4950)]
[New Thread 145009552 (LWP 4951)]
[New Thread -1245549680 (LWP 4952)]
[New Thread -1257985136 (LWP 4953)]
[New Thread -1322370160 (LWP 4954)]
[New Thread -1342538864 (LWP 4955)]
[Thread -1342538864 (LWP 4955) exited]
[New Thread -1342538864 (LWP 4958)]
[Thread -1342538864 (LWP 4958) exited]
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1218315696 (LWP 4947)]
0x0081a703 in memmove () from /lib/libc.so.6
(gdb) bt
#0  0x0081a703 in memmove () from /lib/libc.so.6
#1  0x002c4995 in _STL::__copy_trivial (__first=0xfffffffe, __last=0x3febb6a7, 
    __result=0xfffffffe)
    at /usr/src/debug/OOD680_m2/solver/680/unxlngi6.pro/inc/stl/stl/_algobase.h:150
#2  0x0030888f in _STL::__copy_ptrs<unsigned short*, unsigned short*> (
    __first=0xae855a9e, __last=0xae855a9c, __result=0xae855a9c)
    at /usr/src/debug/OOD680_m2/solver/680/unxlngi6.pro/inc/stl/stl/_algobase.h:197
#3  0x003088c4 in _STL::vector<unsigned short, _STL::allocator<unsigned short>
>::erase (this=0xbfc7aa38, __position=0xae855a9c)
    at /usr/src/debug/OOD680_m2/solver/680/unxlngi6.pro/inc/stl/stl/_vector.h:465
#4  0x002fcc6b in ImplFontCache::GetFallback (this=0xb5cbe50c, 
    pFontList=0xb5c723fc, rOrigFont=@0xb51934f0, rSize=@0xbfc7aa44, 
    nFallbackLevel=1, rMissingGlyphs=@0xbfc7aa38)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:3190
#5  0x002fd007 in OutputDevice::ImplGlyphFallbackLayout (this=0xb5193430, 
    pSalLayout=0xae72576c, rLayoutArgs=@0xbfc7aaa8)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:6292
#6  0x002fd519 in OutputDevice::ImplLayout (this=0xb5193430, 
    rOrigStr=@0xbfc7ab80, nMinIndex=0, nLen=12, rLogicalPos=@0xbfc7ab34, 
    nLogicalWidth=0, pDXArray=0x0, bFilter=false)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:6227
---Type <return> to continue, or q <return> to quit---
#7  0x002fe535 in OutputDevice::GetTextArray (this=0xb5193430, 
    rStr=@0xbfc7ab80, pDXAry=0x0, nIndex=0, nLen=65535)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:5895
#8  0x002fe61a in OutputDevice::GetTextWidth (this=dwarf2_read_address:
Corrupted DWARF expression.
)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:5832
#9  0x002fe690 in OutputDevice::GetCtrlTextWidth (this=0xb5193430, 
    rStr=@0xb51935b0, nIndex=65534, nLen=65535, nStyle=<value optimized out>)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:7212
#10 0x0027b2e8 in HelpTextWindow::SetHelpText (this=0xb5193430, 
    rHelpText=@0xbfc7ad9c)
    at /usr/src/debug/OOD680_m2/vcl/source/app/help.cxx:412
#11 0x0027b710 in HelpTextWindow (this=0xb5193430, pParent=0xb08d390c, 
    rText=@0xbfc7ad9c, nHelpWinStyle=0, nStyle=64)
    at /usr/src/debug/OOD680_m2/vcl/source/app/help.cxx:372
#12 0x0027b9f8 in ImplShowHelpWindow (pParent=0xb08d390c, nHelpWinStyle=0, 
    nStyle=64, rHelpText=@0xbfc7ad9c, rStatusText=@0xb5c43860, 
    rScreenPos=@0xbfc7acf8, pHelpArea=0xbfc7ad8c)
    at /usr/src/debug/OOD680_m2/vcl/source/app/help.cxx:654
#13 0x0027bb7f in Help::ShowQuickHelp (pParent=0xb08d390c, 
    rScreenRect=@0xbfc7ad8c, rHelpText=@0xbfc7ad9c, rLongHelpText=@0xb5c43860, 
    nStyle=64) at /usr/src/debug/OOD680_m2/vcl/source/app/help.cxx:299
#14 0x003c5976 in ToolBox::RequestHelp (this=0xb08d390c, rHEvt=@0xbfc7ae1c)
    at /usr/src/debug/OOD680_m2/vcl/source/window/toolbox.cxx:4866
#15 0x003e3643 in ImplHandleMouseHelpRequest (pChild=0xb08d390c, 
---Type <return> to continue, or q <return> to quit---
    rMousePos=@0xbfc7af8c)
    at /usr/src/debug/OOD680_m2/vcl/source/window/winproc.cxx:326
#16 0x003e4660 in ImplHandleMouseEvent (pWindow=0xb51df2b0, nSVEvent=3, 
    bMouseLeave=0 '\0', nX=210, nY=47, nMsgTime=1302497552, nCode=0, nMode=17)
    at /usr/src/debug/OOD680_m2/vcl/source/window/winproc.cxx:901
#17 0x003e5dd3 in ImplHandleSalMouseMove (pWindow=0xb51df2b0, 
    pEvent=0xbfc7b1e0)
    at /usr/src/debug/OOD680_m2/vcl/source/window/winproc.cxx:2087
#18 0x003e4aa3 in ImplWindowFrameProc (pInst=0xb51df2b0, nEvent=1, 
    pEvent=0xbfc7b1e0)
    at /usr/src/debug/OOD680_m2/vcl/source/window/winproc.cxx:2341
#19 0x032359f0 in SalFrame::CallCallback (this=0xfffffffe, nEvent=65534, 
    pEvent=0xbfc7b1e0) at ../../../inc/salframe.hxx:302
#20 0x03233674 in GtkSalFrame::signalMotion (pEvent=0x8d760a0, 
    frame=0xb5c3370c)
    at /usr/src/debug/OOD680_m2/vcl/unx/gtk/window/gtkframe.cxx:2093
#21 0x071ebdb0 in _gtk_marshal_BOOLEAN__BOXED (closure=0x8f03430, 
    return_value=0xbfc7b36c, n_param_values=2, param_values=0xbfc7b448, 
    invocation_hint=0xbfc7b358, marshal_data=0x32335a8) at gtkmarshalers.c:83
#22 0x014a5f0b in IA__g_closure_invoke (closure=0x8f03430, 
    return_value=0xbfc7b36c, n_param_values=2, param_values=0xbfc7b448, 
    invocation_hint=0xbfc7b358) at gclosure.c:490
#23 0x014b6d63 in signal_emit_unlocked_R (node=0x8d9db80, detail=0, 
    instance=0x8da5c98, emission_return=0xbfc7b608, 
---Type <return> to continue, or q <return> to quit---
    instance_and_params=0xbfc7b448) at gsignal.c:2438
#24 0x014b8027 in IA__g_signal_emit_valist (instance=0x8da5c98, signal_id=37, 
    detail=0, var_args=0xbfc7b68c "��ǿ�`�\b\230\\�\b�80\a\230\\�\bX\204�\b")
    at gsignal.c:2207
#25 0x014b8419 in IA__g_signal_emit (instance=0x8da5c98, signal_id=37, 
    detail=0) at gsignal.c:2241
#26 0x072ff448 in gtk_widget_event_internal (widget=0x8da5c98, event=0x8d760a0)
    at gtkwidget.c:3901
#27 0x071e5253 in IA__gtk_propagate_event (widget=0x8da5c98, event=0x8d760a0)
    at gtkmain.c:2187
#28 0x071e6457 in IA__gtk_main_do_event (event=0x8d760a0) at gtkmain.c:1421
#29 0x043681aa in gdk_event_dispatch (source=0x8d79538, callback=0, 
    user_data=0x0) at gdkevents-x11.c:2320
#30 0x04f45372 in IA__g_main_context_dispatch (context=0x8d79580)
    at gmain.c:2043
#31 0x04f4834f in g_main_context_iterate (context=0x8d79580, block=1, 
    dispatch=1, self=0x8d58a60) at gmain.c:2675
#32 0x04f488b5 in IA__g_main_context_iteration (context=0x8d79580, may_block=1)
    at gmain.c:2734
#33 0x0321719a in GtkXLib::Yield (this=0xb7604308, bWait=true, 
    bHandleAllCurrentEvents=false)
    at /usr/src/debug/OOD680_m2/vcl/unx/gtk/app/gtkdata.cxx:734
#34 0x0345a96e in X11SalInstance::Yield (this=0xb6bdfa30, bWait=true, 
    bHandleAllCurrentEvents=false)
---Type <return> to continue, or q <return> to quit---
    at /usr/src/debug/OOD680_m2/vcl/unx/source/app/salinst.cxx:290
#35 0x002853ff in Application::Yield (bAllEvents=false)
    at /usr/src/debug/OOD680_m2/vcl/source/app/svapp.cxx:550
#36 0x00285494 in Application::Execute ()
    at /usr/src/debug/OOD680_m2/vcl/source/app/svapp.cxx:513
#37 0x00b5a186 in desktop::Desktop::Main (this=0xbfc7bb5c)
    at /usr/src/debug/OOD680_m2/desktop/source/app/app.cxx:1727
#38 0x002892a2 in ImplSVMain ()
    at /usr/src/debug/OOD680_m2/vcl/source/app/svmain.cxx:251
#39 0x00289365 in SVMain ()
    at /usr/src/debug/OOD680_m2/vcl/source/app/svmain.cxx:285
#40 0x00b53d09 in sal_main (argc=1, argv=0xbfc7bc54)
    at /usr/src/debug/OOD680_m2/desktop/source/app/main.cxx:77
#41 0x00b53d55 in main (argc=1, argv=0xbfc7bc54)
    at /usr/src/debug/OOD680_m2/desktop/source/app/main.cxx:71
#42 0x007c324c in __libc_start_main () from /lib/libc.so.6
#43 0x08048481 in _start ()

----
I can not use nv (open driver), because of this bug (
https://bugs.freedesktop.org/show_bug.cgi?id=6212 )
Comment 6 sangu 2006-08-26 23:23:50 EDT
locale LANG=ja_JP.UTF-8 and Installed openoffice.org-langpack-ja_JP-2.0.4-2.1,
the same problem happens.
Comment 7 sangu 2006-08-27 13:05:57 EDT
while starting, impress crashes.

(gdb) r -impress
Starting program: /usr/lib/openoffice.org2.0/program/soffice.bin -impress
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1218676144 (LWP 11946)]
warning: Lowest section in /usr/lib/libicudata.so.36 is .gnu.hash at 000000b4
[New Thread -1218810992 (LWP 11949)]
[New Thread 92093328 (LWP 11950)]
[New Thread 133507984 (LWP 11951)]
[New Thread -1247855728 (LWP 11952)]
[New Thread -1302918256 (LWP 11953)]
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1218676144 (LWP 11946)]
0x00334703 in memmove () from /lib/libc.so.6
(gdb) bt
#0  0x00334703 in memmove () from /lib/libc.so.6
#1  0x0102a995 in _STL::__copy_trivial (__first=0xfffffffe, __last=0x3ff8ea85, 
    __result=0xfffffffe)
    at /usr/src/debug/OOD680_m2/solver/680/unxlngi6.pro/inc/stl/stl/_algobase.h:150
#2  0x0106e88f in _STL::__copy_ptrs<unsigned short*, unsigned short*> (
    __first=0xb10a6a16, __last=0xb10a6a14, __result=0xb10a6a14)
    at /usr/src/debug/OOD680_m2/solver/680/unxlngi6.pro/inc/stl/stl/_algobase.h:197
#3  0x0106e8c4 in _STL::vector<unsigned short, _STL::allocator<unsigned short>
>::erase (this=0xbf999840, __position=0xb10a6a14)
    at /usr/src/debug/OOD680_m2/solver/680/unxlngi6.pro/inc/stl/stl/_vector.h:465
#4  0x01062c6b in ImplFontCache::GetFallback (this=0xb5c6650c, 
    pFontList=0xb5c1a3ac, rOrigFont=@0xb1b656d8, rSize=@0xbf99984c, 
    nFallbackLevel=1, rMissingGlyphs=@0xbf999840)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:3190
#5  0x01063007 in OutputDevice::ImplGlyphFallbackLayout (this=0xb1b65618, 
    pSalLayout=0xb0b85d84, rLayoutArgs=@0xbf9998b0)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:6292
#6  0x01063519 in OutputDevice::ImplLayout (this=0xb1b65618, 
    rOrigStr=@0xb0ba4f70, nMinIndex=0, nLen=3, rLogicalPos=@0xbf99993c, 
---Type <return> to continue, or q <return> to quit---
    nLogicalWidth=0, pDXArray=0x0, bFilter=false)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:6227
#7  0x01064535 in OutputDevice::GetTextArray (this=0xb1b65618, 
    rStr=@0xb0ba4f70, pDXAry=0x0, nIndex=0, nLen=65535)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:5895
#8  0x0106461a in OutputDevice::GetTextWidth (this=dwarf2_read_address:
Corrupted DWARF expression.
)
    at /usr/src/debug/OOD680_m2/vcl/source/gdi/outdev3.cxx:5832
#9  0x011796aa in ImplListBoxWindow::ImplCalcEntryMetrics (this=0xb1b65618, 
    rEntry=@0xfffffffe, bUpdateMetrics=1 '\001')
    at /usr/src/debug/OOD680_m2/vcl/source/control/ilstbox.cxx:683
#10 0x0117a7cf in ImplListBoxWindow::InsertEntry (this=0xb1b65618, nPos=65535, 
    pNewEntry=0xb0ba4f70)
    at /usr/src/debug/OOD680_m2/vcl/source/control/ilstbox.cxx:775
#11 0x0117a900 in ImplListBox::InsertEntry (this=0xb1b6550c, nPos=65535, 
    rStr=@0xbf99a200)
    at /usr/src/debug/OOD680_m2/vcl/source/control/ilstbox.cxx:2079
#12 0x01182b62 in ListBox::InsertEntry (this=0xb10761b4, rStr=@0xbf99a200, 
    nPos=65535) at /usr/src/debug/OOD680_m2/vcl/source/control/lstbox.cxx:1018
#13 0x02f87de3 in AssistentDlgImpl (this=0xb67b4408, pWindow=0xb5bddb68, 
    rFinishLink=@0xbf99a254, bAutoPilot=0 '\0')
    at /usr/src/debug/OOD680_m2/sd/source/ui/dlg/dlgass.cxx:632
#14 0x02f8894b in AssistentDlg (this=0xb5bddb68, pParent=0x0, 
---Type <return> to continue, or q <return> to quit---
    bAutoPilot=0 '\0')
    at /usr/src/debug/OOD680_m2/sd/source/ui/dlg/dlgass.cxx:1938
#15 0x02f7d407 in SdAbstractDialogFactory_Impl::CreateAssistentDlg (
    this=0xb12565fc, rResId=@0xbf99a320, pParent=0x0, bAutoPilot=0 '\0')
    at /usr/src/debug/OOD680_m2/sd/source/ui/dlg/sddlgfact.cxx:527
#16 0x03726506 in SdModule::ExecuteNewDocument (this=0xb275ae94, 
    rReq=@0xbf99a610)
    at /usr/src/debug/OOD680_m2/sd/source/ui/app/sdmod1.cxx:624
#17 0x03727587 in SdModule::Execute (this=0xb275ae94, rReq=@0xbf99a610)
    at /usr/src/debug/OOD680_m2/sd/source/ui/app/sdmod1.cxx:250
#18 0x0372545a in SfxStubSdModuleExecute (pShell=0xb275ae94, rReq=@0xbf99a610)
    at ../../../unxlngi6.pro/inc/sdslots.hxx:659
#19 0x06dddc10 in SfxShell::CallExec (this=0xb275ae94, 
    pFunc=0x3725440 <SfxStubSdModuleExecute(SfxShell*, SfxRequest&)>, 
    rReq=@0xbf99a610) at ../../inc/shell.hxx:226
#20 0x06de8ff0 in SfxShell::ExecuteSlot (this=0xb275ae94, rReq=@0xbf99a610, 
    pIF=0x0) at /usr/src/debug/OOD680_m2/sfx2/source/control/shell.cxx:1010
#21 0x03823a5e in SdUnoModule::dispatchWithNotification (this=0xb270db28, 
    aURL=@0xbf99a680, aArgs=@0xbf99a6d8, xListener=@0xbf99a6d4)
    at /usr/src/debug/OOD680_m2/sd/source/ui/unoidl/unomodule.cxx:98
#22 0x04a81ae1 in framework::DispatchHelper::executeDispatch (this=0xb1b6eb00, 
    xDispatchProvider=@0xbf99ae18, sURL=@0xbf99ae14, 
---Type <return> to continue, or q <return> to quit---
    sTargetFrameName=@0xbf99ae88, nSearchFlags=0, lArguments=@0xbf99ae24)
    at /usr/src/debug/OOD680_m2/framework/source/services/dispatchhelper.cxx:206
#23 0x06cd747c in SfxApplication::OfaExec_Impl (this=0xb5b2ccc0, 
    rReq=@0xbf99b01c)
    at /usr/src/debug/OOD680_m2/sfx2/source/appl/appserv.cxx:1143
#24 0x06ccd014 in SfxStubSfxApplicationOfaExec_Impl (pShell=0xb5b2ccc0, 
    rReq=@0xbf99b01c) at ../../unxlngi6.pro/inc/sfxslots.hxx:1117
#25 0x06dddc10 in SfxShell::CallExec (this=0xb5b2ccc0, 
    pFunc=0x6ccd006 <SfxStubSfxApplicationOfaExec_Impl(SfxShell*, SfxRequest&)>,
rReq=@0xbf99b01c) at ../../inc/shell.hxx:226
#26 0x06de8ff0 in SfxShell::ExecuteSlot (this=0xb5b2ccc0, rReq=@0xbf99b01c, 
    pIF=0x0) at /usr/src/debug/OOD680_m2/sfx2/source/control/shell.cxx:1010
#27 0x06db3abf in SfxFrameLoader_Impl::load (this=0xb2733c90, 
    rArgs=@0xbf99b26c, rFrame=@0xbf99b278)
    at /usr/src/debug/OOD680_m2/sfx2/source/view/frmload.cxx:408
#28 0x04ad91fd in framework::LoadEnv::impl_loadContent (this=0xbf99b2ec)
    at /usr/src/debug/OOD680_m2/framework/source/loadenv/loadenv.cxx:1326
#29 0x04ad9413 in framework::LoadEnv::startLoading (this=0xbf99b2ec)
    at /usr/src/debug/OOD680_m2/framework/source/loadenv/loadenv.cxx:547
#30 0x04ad9a48 in framework::LoadEnv::loadComponentFromURL (
    xLoader=@0xbf99b400, xSMGR=@0xbf99b3fc, sURL=@0xbf99b640, 
---Type <return> to continue, or q <return> to quit---
    sTarget=@0xbf99b58c, nFlags=0, lArgs=@0xbf99b594)
    at /usr/src/debug/OOD680_m2/framework/source/loadenv/loadenv.cxx:359
#31 0x04a28415 in framework::Desktop::loadComponentFromURL (this=0xb5b57cb4, 
    sURL=@0xbf99b640, sTargetFrameName=@0xbf99b58c, nSearchFlags=0, 
    lArguments=@0xbf99b594)
    at /usr/src/debug/OOD680_m2/framework/source/services/desktop.cxx:874
#32 0x00f47d1b in desktop::DispatchWatcher::executeDispatchRequests (
    this=0xb283944c, aDispatchRequestsList=@0xbf99b6a0)
    at /usr/src/debug/OOD680_m2/desktop/source/app/dispatchwatcher.cxx:378
#33 0x00f40929 in desktop::OfficeIPCThread::ExecuteCmdLineRequests (
    aRequest=@0xbf99b6d0)
    at /usr/src/debug/OOD680_m2/desktop/source/app/officeipcthread.cxx:873
#34 0x00f3042f in desktop::Desktop::OpenDefault ()
    at /usr/src/debug/OOD680_m2/desktop/source/app/app.cxx:2684
#35 0x00f382c0 in desktop::Desktop::OpenClients ()
    at /usr/src/debug/OOD680_m2/desktop/source/app/app.cxx:2627
#36 0x00f382f3 in desktop::Desktop::OpenClients_Impl (this=0xbf99c09c, 
    pvoid=0x0) at /usr/src/debug/OOD680_m2/desktop/source/app/app.cxx:1949
#37 0x00f38354 in desktop::Desktop::LinkStubOpenClients_Impl (
    pThis=0xbf99c09c, pCaller=0x0)
    at /usr/src/debug/OOD680_m2/desktop/source/app/app.cxx:1945
#38 0x00fe2ea0 in Link::Call (this=0x3ff8ea85, pCaller=0x0)
---Type <return> to continue, or q <return> to quit---
    at /usr/src/debug/OOD680_m2/solver/680/unxlngi6.pro/inc/tools/link.hxx:158
#39 0x0114b5fa in ImplWindowFrameProc (pInst=0xb5b57674, nEvent=22, 
    pEvent=0xb5b23eb0)
    at /usr/src/debug/OOD680_m2/vcl/source/window/winproc.cxx:2027
#40 0x01c5ec48 in SalFrame::CallCallback (this=0xfffffffe, nEvent=65534, 
    pEvent=0xb5b23eb0) at ../../../inc/salframe.hxx:302
#41 0x01c842d6 in SalDisplay::DispatchInternalEvent (this=0xb6b93008)
    at /usr/src/debug/OOD680_m2/vcl/unx/source/app/saldisp.cxx:2402
#42 0x016d832c in GtkXLib::userEventFn (data=0xb75ac308)
    at /usr/src/debug/OOD680_m2/vcl/unx/gtk/app/gtkdata.cxx:674
#43 0x016d8353 in call_userEventFn (data=0xb75ac308)
    at /usr/src/debug/OOD680_m2/vcl/unx/gtk/app/gtkdata.cxx:647
#44 0x01650611 in g_idle_dispatch (source=0x84d51c8, callback=0xfffffffe, 
    user_data=0xb75ac308) at gmain.c:3924
#45 0x01652372 in IA__g_main_context_dispatch (context=0x83d1590)
    at gmain.c:2043
#46 0x0165534f in g_main_context_iterate (context=0x83d1590, block=0, 
    dispatch=1, self=0x83b0a60) at gmain.c:2675
#47 0x016558b5 in IA__g_main_context_iteration (context=0x83d1590, may_block=0)
    at gmain.c:2734
#48 0x016d8183 in GtkXLib::Yield (this=0xb75ac308, bWait=true, 
    bHandleAllCurrentEvents=false)
---Type <return> to continue, or q <return> to quit---
    at /usr/src/debug/OOD680_m2/vcl/unx/gtk/app/gtkdata.cxx:729
#49 0x01c8696e in X11SalInstance::Yield (this=0xb6b87a58, bWait=true, 
    bHandleAllCurrentEvents=false)
    at /usr/src/debug/OOD680_m2/vcl/unx/source/app/salinst.cxx:290
#50 0x00feb3ff in Application::Yield (bAllEvents=false)
    at /usr/src/debug/OOD680_m2/vcl/source/app/svapp.cxx:550
#51 0x00feb494 in Application::Execute ()
    at /usr/src/debug/OOD680_m2/vcl/source/app/svapp.cxx:513
#52 0x00f35186 in desktop::Desktop::Main (this=0xbf99c09c)
    at /usr/src/debug/OOD680_m2/desktop/source/app/app.cxx:1727
#53 0x00fef2a2 in ImplSVMain ()
    at /usr/src/debug/OOD680_m2/vcl/source/app/svmain.cxx:251
#54 0x00fef365 in SVMain ()
    at /usr/src/debug/OOD680_m2/vcl/source/app/svmain.cxx:285
#55 0x00f2ed09 in sal_main (argc=2, argv=0xbf99c194)
    at /usr/src/debug/OOD680_m2/desktop/source/app/main.cxx:77
#56 0x00f2ed55 in main (argc=2, argv=0xbf99c194)
    at /usr/src/debug/OOD680_m2/desktop/source/app/main.cxx:71
#57 0x002dd24c in __libc_start_main () from /lib/libc.so.6
#58 0x08048481 in _start ()
Comment 8 Caolan McNamara 2006-08-28 05:19:05 EDT
vector::erase(std::remove(...)) is failing when remove returns vector::end. This
is *supposed* to be ok, but is crashing in stlport. I can avoid this with
checking to see if remove returns a different end than the current one, and only
erase in this case.
Comment 9 Caolan McNamara 2006-08-28 05:42:39 EDT
*** Bug 204282 has been marked as a duplicate of this bug. ***
Comment 10 Caolan McNamara 2006-08-28 05:44:45 EDT
So this should happen when there are is a glyph which don't exist in the current
font, and so glyph replacement kicks in, but the crash would only happen if the
glyph is used >=2 times in the run of text being rendered. Fix in progress
Comment 11 Caolan McNamara 2006-08-28 06:25:33 EDT
ok, take 2

Note You need to log in before you can comment on or make changes to this bug.