Bug 20418 - RFE: .bashrc
RFE: .bashrc
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rootfiles (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-06 07:46 EST by Gerald Teschl
Modified: 2014-03-16 22:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 07:42:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2000-11-06 07:46:07 EST
What about adding
----------
if echo $PATH | grep -vq sbin
then
       PATH=$PATH:/sbin:/usr/sbin
 fi
----------
to .bashrc. I find this useful if I do "su" rahter than
"su -" since I want to stay in the same directory.

In addition, what about adding a .gnupg/pubring.gpg
containing the RedHat key?
Comment 1 Pekka Savola 2000-11-06 15:33:03 EST
Seconded.  Many people aren't really aware of 'su -', so this would be a nice addition.

Personally, I always add the RH key to root's public keyring.  Adding this might be a little more
problematic than .bashrc though.
Comment 2 Daniel Roesen 2000-11-07 07:42:15 EST
Hm, I don't think changing su semantics is a good idea. The idea of su with "-" 
is to leave environment intact. Yes, having sbins in PATH for su without "-" is 
convenient, but... :->

I second the request for a root pubring containing RH's key.
Comment 3 Bill Nottingham 2001-01-30 16:04:59 EST
I'd agree that changing the semantics of su is probably not good.

As for the keyring, I'm more comfortable with leaving it out;
up2date and the like always prompt to add it anyway.
Comment 4 Daniel Roesen 2001-01-30 16:17:31 EST
Where do you see the problem with including the key? There are people like me
who will never use up2date. And distributing the key on the official CDs and
ISOs is more secure than getting the key from
http://www.redhat.com/about/contact/pgpkey.html (which is not even SSL-secured).

Note You need to log in before you can comment on or make changes to this bug.