Bug 204221 - kernel BUGs when copying from ext3 to reiserfs
kernel BUGs when copying from ext3 to reiserfs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 03:22 EDT by Eric Harney
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 00:05:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (8.91 KB, text/plain)
2006-08-27 03:22 EDT, Eric Harney
no flags Details

  None (edit)
Description Eric Harney 2006-08-27 03:22:46 EDT
Description of problem:
When issuing a "cp -a --preserve=all folder_a /mnt/storage/" from an ext3 volume
to a reiserfs volume, cp was killed.  dmesg showed multiple stack traces and BUG
messages.

Version-Release number of selected component (if applicable):
Linux packetbane 2.6.17-1.2157_FC5 #1 SMP Tue Jul 11 22:53:56 EDT 2006 x86_64
x86_64 x86_64 GNU/Linux

How reproducible:
Unable to reproduce.

Steps to Reproduce:
Appeared when copying a large folder with many files and subfolders from an ext3
volume to a reiserfs volume.  Both volumes are on LVM, which is on top of mdraid.

Attaching dmesg output which includes multiple BUG messages and stack traces
from the same event.  Seems to indicate a kernel bug.
Comment 1 Eric Harney 2006-08-27 03:22:46 EDT
Created attachment 134994 [details]
dmesg output
Comment 2 David Lawrence 2006-09-05 15:05:21 EDT
Changing to proper owner, kernel-maint.
Comment 3 Dave Jones 2006-09-11 00:05:33 EDT
Reiserfs oopses are better off reported in the upstream bugzilla, or posted to
linux-kernel@vger.kernel.org, where the upstream developers may give it attention.
Comment 4 Eric Harney 2006-09-12 11:35:58 EDT
The upstream bugzilla Enter Bug page indicates that they only want bugs from
mainline or -mm kernels.  Is sending Fedora kernel bugs up to them a standard
procedure?
Comment 5 Dave Jones 2006-09-14 02:20:22 EDT
Yes, as we don't carry any patches to reiserfs, so it's extremely likely that
this is an upstream bug.

Note You need to log in before you can comment on or make changes to this bug.