This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 204236 - pkg-config does't work (buggy libjs.pc)
pkg-config does't work (buggy libjs.pc)
Status: CLOSED DUPLICATE of bug 204232
Product: Fedora
Classification: Fedora
Component: js (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 10:31 EDT by František Dvořák
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 04:16:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Spec file fix. (373 bytes, patch)
2006-08-27 10:33 EDT, František Dvořák
no flags Details | Diff

  None (edit)
Description František Dvořák 2006-08-27 10:31:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.8.0.6) Gecko/20060808 Fedora/1.5.0.6-2.fc5 Firefox/1.5.0.6 pango-text

Description of problem:
Variables written to libjs.pc aren't evalued ==> there are ${_prefix}, ${_libdir}, ... instead of the proper values.

Version-Release number of selected component (if applicable):
js-devel-1.5-5.fc5, js-devel-1.5-5.fc6

How reproducible:
Always


Steps to Reproduce:
1. pkg-config libjs --libs


Actual Results:
Variable '_prefix' not defined in '/tmp/myroot/usr/lib/pkgconfig/libjs.pc'

Expected Results:
-ljs

Additional info:
Replacing ${_prefix}, ... by %{_prefix} in specfiles is needed.
Comment 1 František Dvořák 2006-08-27 10:33:15 EDT
Created attachment 134998 [details]
Spec file fix.

Tested.
Comment 2 Matthias Saou 2006-08-28 04:16:48 EDT

*** This bug has been marked as a duplicate of 204232 ***

Note You need to log in before you can comment on or make changes to this bug.