Bug 204241 - Monodevelop fails to start, monodoc gac not found
Monodevelop fails to start, monodoc gac not found
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 12:10 EDT by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-02 05:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2006-08-27 12:10:59 EDT
Description of problem:
When executing monodevelop on my x86_64 box I get the following:

which: no mozilla in
(/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/david/bin)
** (./MonoDevelop.exe:636): WARNING **: The following assembly referenced from
/usr/lib/monodevelop/AddIns/MonoDevelop.Documentation.dll could not be loaded:
     Assembly:   monodoc    (assemblyref_index=1)
     Version:    1.0.0.0
     Public Key: 0738eb9f132ed756
The assembly was not found in the Global Assembly Cache, a path listed in the
MONO_PATH environment variable, or in the location of the executing assembly
(/usr/lib/monodevelop/bin/../AddIns).
** (./MonoDevelop.exe:636): WARNING **: Could not load file or assembly
'monodoc, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or
one of its dependencies.
2006-08-27 18:04:09,800 [-1431558336] ERROR MonoDevelop.Core.ILoggingService
[(null)] - Add-in failed to load: MonoDevelop.Documentation
2006-08-27 18:04:09,828 [-1431558336] ERROR MonoDevelop.Core.ILoggingService
[(null)] - System.Reflection.ReflectionTypeLoadException: The classes in the
module cannot be loaded.
  at <0x00000> <unknown method>
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] 
  at MonoDevelop.Core.AddIns.DefaultAddInTree.LoadCodonsAndConditions
(System.Reflection.Assembly assembly) [0x00000] 
  at MonoDevelop.Core.AddIns.DefaultAddInTree.LoadAssembly (System.String
fileName) [0x00000] 
  at MonoDevelop.Core.AddIns.AddIn.AddRuntimeLibraries (System.String path,
System.Xml.XmlElement el) [0x00000] 
  at MonoDevelop.Core.AddIns.AddIn.Initialize (System.String fileName) [0x00000] 
  at MonoDevelop.Core.AddIns.AddInTreeSingleton.InsertAddIn (System.String
addInFile) [0x00000] 
2006-08-27 18:04:10,206 [-1431558336] ERROR MonoDevelop.Core.ILoggingService
[(null)] - Add-in failed to load: MonoDevelop.Ide
2006-08-27 18:04:10,207 [-1431558336] ERROR MonoDevelop.Core.ILoggingService
[(null)] - MonoDevelop.Core.AddIns.MissingDependencyException: Required add-in
not found: MonoDevelop.Documentation
  at MonoDevelop.Core.AddIns.AddIn.CheckDependencies (System.Xml.XmlElement
deps) [0x00000] 
  at MonoDevelop.Core.AddIns.AddIn.Initialize (System.String fileName) [0x00000] 
  at MonoDevelop.Core.AddIns.AddInTreeSingleton.InsertAddIn (System.String
addInFile) [0x00000] 
System.NullReferenceException: Object reference not set to an instance of an object
  at MonoDevelop.Core.AddIns.AddInService.StartApplication (System.String
addinId, System.String[] parameters) [0x00000] 


Version-Release number of selected component (if applicable):
monodoc-1.1.16-1.fc6
monodevelop-0.11-16.fc6

How reproducible:
100%

Steps to Reproduce:
1. execute monodevelop
  
Actual results:
obtaining the above output

Expected results:
glorious Monodevelop goodness
Comment 1 Paul F. Johnson 2006-08-27 15:49:10 EDT
Okay, I can see the problem - I'll try and get a fix out tonight. Thanks for the
report.
Comment 2 Paul F. Johnson 2006-08-27 16:14:26 EDT
I can't currently rebuild monodevelop as gecko-sharp2 is broken for x86_64
(rawhide 0.11-11, BZ #204254). I can fix that locally, but the resulting rpm
will be broken.
Comment 3 Paul F. Johnson 2006-08-30 19:20:58 EDT
There seems to be a problem between the current gtk-sharp2 and the previous
version which means I can't currently compile.
Comment 4 Paul F. Johnson 2006-08-30 21:12:54 EDT
I really need more sleep!

monodoc should be in tomorrows push. I'll leave this bug open for now incase it
doesn't fix the problem
Comment 5 David Nielsen 2006-09-01 23:31:44 EDT
Well it still doesn't start following the monodoc update, I get the following
output - I am however not sure if it's related to the original problem:

System.Reflection.TargetInvocationException: Exception has been thrown by the
target of an invocation. ---> System.TypeInitializationException: An exception
was thrown by the type initializer for
MonoDevelop.GtkCore.GuiBuilder.GuiBuilderService --->
System.TypeInitializationException: An exception was thrown by the type
initializer for Stetic.Registry ---> System.ArgumentException: <enum> node for
Gdk.WindowTypeHint is missing some values
  at Stetic.EnumDescriptor..ctor (System.Xml.XmlElement elem) [0x00000] 
  at Stetic.WidgetLibrary.Load (System.Xml.XmlDocument objects) [0x00000] 
  at Stetic.AssemblyWidgetLibrary.Load () [0x00000] 
  at Stetic.Registry.RegisterWidgetLibrary (Stetic.WidgetLibrary library) [0x00000] 
  at Stetic.Registry..cctor () [0x00000] --- End of inner exception stack trace ---

  at <0x00000> <unknown method>
  at Stetic.Project..ctor () [0x00000] 
  at MonoDevelop.GtkCore.GuiBuilder.GuiBuilderService..cctor () [0x00000] ---
End of inner exception stack trace ---

  at <0x00000> <unknown method>
  at MonoDevelop.GtkCore.GuiBuilder.GuiBuilderPalettePad..ctor () [0x00000] 
  at <0x00000> <unknown method>
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke
(object,object[])
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags
invokeAttr, System.Reflection.Binder binder, System.Object[] parameters,
System.Globalization.CultureInfo culture) [0x00000] --- End of inner exception
stack trace ---

  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags
invokeAttr, System.Reflection.Binder binder, System.Object[] parameters,
System.Globalization.CultureInfo culture) [0x00000] 
  at System.Reflection.MonoCMethod.Invoke (BindingFlags invokeAttr,
System.Reflection.Binder binder, System.Object[] parameters,
System.Globalization.CultureInfo culture) [0x00000] 
  at System.Reflection.ConstructorInfo.Invoke (System.Object[] parameters)
[0x00000] 
  at System.Activator.CreateInstance (System.Type type, Boolean nonPublic)
[0x00000] 
  at System.Activator.CreateInstance (System.Type type) [0x00000] 
  at MonoDevelop.Core.AddIns.AddIn.CreateObject (System.String className) [0x00000] 
  at MonoDevelop.Ide.Codons.PadCodon.CreatePad () [0x00000] 
  at MonoDevelop.Ide.Codons.PadCodon.BuildItem (System.Object owner,
System.Collections.ArrayList subItems,
MonoDevelop.Core.AddIns.ConditionCollection conditions) [0x00000] 
  at MonoDevelop.Core.AddIns.DefaultAddInTreeNode.BuildChildItems (System.Object
caller) [0x00000] 
  at MonoDevelop.Core.AddIns.AddInService.GetTreeItems (System.String path,
System.Type itemType) [0x00000] 
  at MonoDevelop.Ide.Gui.DefaultWorkbench.InitializeLayout (IWorkbenchLayout
workbenchLayout) [0x00000] 
  at MonoDevelop.Ide.Gui.Workbench.Initialize (IProgressMonitor monitor) [0x00000] 
  at MonoDevelop.Ide.Gui.IdeApp.Initialize (IProgressMonitor monitor) [0x00000] 
  at MonoDevelop.Ide.Gui.IdeStartup.Run (System.String[] args) [0x00000] 
Comment 6 Paul F. Johnson 2006-09-02 05:41:48 EDT
This isn't a monodoc problem, but looks to be be more of a gtk-sharp2 problem.
I'll rebuild it here and try and build monodevelop. In the meanwhile, I'll close
this bug and have opened one on monodevelop (#205012).

Note You need to log in before you can comment on or make changes to this bug.