Bug 204270 - Development kernels break SecuROM in Wine
Development kernels break SecuROM in Wine
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-08-27 22:21 EDT by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.18-1.2784.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-15 21:14:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2006-08-27 22:21:27 EDT
Description of problem:
When using previous version of Wine, (eg 0.9.12, 0.9.13) CDs where autodetected
using HAL and added to the Wine drives, and therefore I could play Warcraft III,
Starcraft and other games without a no-cd patch. Now, for some reason, CDs are
still detected and added, yet the game requests again and again for a CD in the

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Warcraft III
2. You can even run install.exe and then click 'Play Warcraft' - The CD works
and is mounted.
3. It will request for a valid CD again and again, even when you started it from
the CD it needs!
Actual results:
The game asks for a valid CD

Expected results:
It workes like in versions 0.9.12 and 0.9.13 (FC5)

Additional info:
Could this be a HAL bug?
Comment 1 Stewart Adam 2006-08-27 22:58:06 EDT
I just installed the 0.9.16 version from the FC4 repos, it's still happening -
So either 0.9.16 is broken, too, or maybe it's something from the development
repos that's breaking it.

On the Wine HQ page, it says that using GCC 4 / 4.1 breaks CD protection. Maybe
the RedHat / Fedora build servers are using this?
Comment 2 Andreas Bierfert 2006-08-28 00:05:24 EDT
Hm, well for devel and fe5 and fe4 versions gcc4 is used so this might be the
reason why it cannot find/use your cd... you could try the fe3 version and see
if that works...
Comment 3 Stewart Adam 2006-08-28 12:52:25 EDT
Is it possible to change building the Wine RPMS back to GCC 3.x?
Comment 4 Stewart Adam 2006-08-28 20:22:14 EDT
I just tried the fc3 versions, still broken.
Comment 5 Stewart Adam 2006-08-30 19:55:45 EDT
I figured it out - I installed the FC5 kernel onto the FC6 system, and now wine
works properly. I've changed the title to reflect the real problem - apparently
the newer kernels break SecuROM in Wine.
Comment 6 Andreas Bierfert 2006-09-01 04:20:16 EDT
CC'ing redhat kernel folks :) Hope you are the right one Don...
Comment 7 Stewart Adam 2006-09-01 16:51:30 EDT
It's weird, though, because the FC5 is also the 2.6.17 line so it much be a
minor change...
Comment 8 Stewart Adam 2006-09-04 11:46:43 EDT
** much should read "must"... Sorry for the mistake.
Comment 9 Andreas Bierfert 2006-09-17 11:14:47 EDT
I just pushed a new wine version... please retry with it maybe the bug is solved.
Comment 10 Stewart Adam 2006-09-22 16:47:13 EDT
Nope, not working with Wine 0.21 and kernel 2.6.17-1.2647.fc6
Comment 11 Stewart Adam 2006-09-24 21:39:25 EDT
Still not working with 2.6.18-1.2689 kernel and Wine 0.21
Comment 12 Stewart Adam 2006-10-03 13:00:21 EDT
Any news on this issue?
Comment 13 Stewart Adam 2006-10-05 20:32:35 EDT
Again, not working with kernel 2.6.18-1.2726, Wine 0.22 - I've also done some
reaseach on the issue and found others using 2.6.17/18 are experiencing similar
symptoms, and it had to do with a NX bug - I've tried booting with:
in my 'kernel' line and it still doesn't work. Odd...
Comment 14 Stewart Adam 2006-10-15 21:14:28 EDT
Seems to be fixed in kernel-2.6.18-1.2784.fc6 - Here's the changelog:

* Thu Oct 12 2006 Dave Jones <davej@redhat.com>
- Fix unbalanced locking in decnet.
  (You know we're getting close to a release when I'm 
   fixing bugs in DECNet of all things).
  Both users will be very happy this fix made it into FC6.
- Improve mm debugging in rmap sanity checking.
- rt-mutex: fixup rt-mutex debug code
- DLM: Fix recvmsg iovec length
- Remove reference to the dead module_upgrade (Bill Nottingham).
- Fix kernel oops with bluetooth/rfcomm. (#208628)
- Fix utrace so that SIGTRAP can be caught. (#205659)
- GFS2: Fix kunmap_atomic for highmem systems
- APM lockdep fix.
- Fix broken gdb/strace of threaded programs (#209873)

* Wed Oct 11 2006 Jon Masters <jcm@redhat.com>
- Silence a stupid error in find-provides for non-kABI subpackages.

* Wed Oct 11 2006 Dave Jones <davej@redhat.com>
- Silence some useless messages that still get printed with 'quiet'
- utrace: fix signal deliver on ptrace_detach()
- Unmacroise the debuginfo generation.

I guess something in there fixed it... Closing...

Note You need to log in before you can comment on or make changes to this bug.