Bug 204272 - Incomplete classmap db files resulting in partially interpreted (slow) apps
Incomplete classmap db files resulting in partially interpreted (slow) apps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 00:33 EDT by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.4.2.0-40jpp.103
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 03:53:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2006-08-28 00:33:33 EDT
Description of problem:
Many of the classmap .db files we have are incomplete, resulting in partially
interpreted code that should be running fully native.  
See this thread for details:
https://www.redhat.com/archives/fedora-devel-java-list/2006-August/msg00031.html
Especially this one:
https://www.redhat.com/archives/fedora-devel-java-list/2006-August/msg00034.html

I'm filing this against java-1.4.2-gcj-compat because it owns aot-compile-rpm,
but I don't know where the problem really lies.  This is just a starting point.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Note You need to log in before you can comment on or make changes to this bug.