Bug 204371 - innd.init script should use ctlinnd to stop the server
innd.init script should use ctlinnd to stop the server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: inn (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 15:02 EDT by James Ralston
Modified: 2008-01-07 10:51 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 10:51:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make innd.init use ctlinnd to shutdown innd (772 bytes, patch)
2006-08-28 15:02 EDT, James Ralston
no flags Details | Diff

  None (edit)
Description James Ralston 2006-08-28 15:02:35 EDT
The recommended method to shut down innd is to use "ctlinnd throttle" followed
by "ctlinnd shutdown".  However, the innd.init script doesn't do this; it simply
calls "killproc innd".  This is non-optimal.

The attached patch modifies the behavior of innd.init when stopping the server
to first use ctlinnd, then fallback to using killproc if ctlinnd doesn't work
for some reason.

(I was fairly conservative with the timeouts; it probably wouldn't be
unreasonable to shorten them a little bit.)
Comment 1 James Ralston 2006-08-28 15:02:35 EDT
Created attachment 135072 [details]
patch to make innd.init use ctlinnd to shutdown innd
Comment 2 Martin Stransky 2006-08-29 08:02:19 EDT
Applied to CVS...
Comment 3 Michael Schwendt 2007-12-29 15:54:43 EST
The following on F-8 appears to be related to this patch.

# service innd start
Starting INND system: Starting innd.
                                                           [  OK  ]
# service innd stop
Stopping INND service (gently): /etc/init.d/innd: line 56: /ctlinnd: No such
file or directory
Stopping INND service (the hard way):                      [  OK  ]

# rpm -ql inn |grep ctli
/usr/lib/news/bin/ctlinnd
/usr/share/man/man8/ctlinnd.8.gz

# rpm -q inn
inn-2.4.3-7.fc8
Comment 4 Ondrej Vasik 2008-01-07 10:51:34 EST
Thanks for report and reopening, but it is not related. Problem you see is
related to #401241 and was caused by bad changes by previous maintainer in
initscript review changes - because of them stop() can't see $NEWSBIN directory
and can't execute ctlinnd to gently shutdown innd. Closing RAWHIDE again, please
use #401241 for further discussion about that problem.

Note You need to log in before you can comment on or make changes to this bug.