Bug 204434 - email title is wrong when using splithosts
email title is wrong when using splithosts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: logwatch (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 23:41 EDT by Russell Coker
Modified: 2008-07-24 16:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0750
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix this bug (2.69 KB, patch)
2006-08-29 02:49 EDT, Russell Coker
no flags Details | Diff

  None (edit)
Description Russell Coker 2006-08-28 23:41:38 EDT
$Config{'splithosts'} = 1;

I have the above in /etc/cron.daily/00-logwatch and have the logs from multiple
machines ending up in syslog on a machine named "mg******".

The machine named "fl******" gets it's log entry processed first which means
that the title of the email is "LogWatch for fl******" instead of "LogWatch for
mg******".

It seems to me that a more appropriate email title when splithosts is used would
be "LogWatch run on $Config{'hostname'}".

I believe that the correct solution to this problem would involve having
$hostname refer to the host that is being processed and $Config{'hostname'}
refer to the machine that is running the logwatch.
Comment 1 Russell Coker 2006-08-29 02:49:55 EDT
Created attachment 135106 [details]
patch to fix this bug

This patch works for me on RHEL4.4.  Let me know if it would help if I wrote
and tested a patch for rawhide.
Comment 2 Ivana Varekova 2007-10-26 04:53:56 EDT
Putting on the proposed list.
Comment 3 RHEL Product and Program Management 2007-11-28 23:24:40 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 errata-xmlrpc 2008-07-24 16:01:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0750.html

Note You need to log in before you can comment on or make changes to this bug.