Bug 204450 - /etc/init.d/tomcat5 start gives "-mindepth" error on find
/etc/init.d/tomcat5 start gives "-mindepth" error on find
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vivek Lakshmanan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-29 02:54 EDT by Bryce Nesbitt
Modified: 2008-01-05 08:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 08:10:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2006-08-29 02:54:44 EDT
# /etc/init.d/tomcat5 start
Starting tomcat5: find: warning: you have specified the -mindepth option after a
non-option argument -type, but options are not positional (-mindepth affects
tests specified before it as well as those specified after it).  Please specify
options before other arguments.

find: warning: you have specified the -maxdepth option after a non-option
argument -type, but options are not positional (-maxdepth affects tests
specified before it as well as those specified after it).  Please specify
options before other arguments.

Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:
                                                           [  OK  ]
Comment 1 Davide Bolcioni 2006-10-25 11:05:58 EDT
The problem is in /usr/share/tomcat5/bin/relink, where

for webapp in $(find /var/lib/tomcat5/webapps -type d -mindepth 1 -maxdepth 2) ; do
    [ -d "$webapp/WEB-INF/lib" ] && rebuild-jar-repository $webapp/WEB-INF/lib
done

should be

for webapp in $(find /var/lib/tomcat5/webapps -mindepth 1 -maxdepth 2 -type d) ; do
    [ -d "$webapp/WEB-INF/lib" ] && rebuild-jar-repository $webapp/WEB-INF/lib
done
Comment 2 Devrim GUNDUZ 2008-01-05 08:10:29 EST
This is fixed in the latest releases, closing.

Note You need to log in before you can comment on or make changes to this bug.