Bug 204471 - Can't mount GFS filesystem: error: jid is -2, try rw
Can't mount GFS filesystem: error: jid is -2, try rw
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Teigland
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-29 08:37 EDT by Christine Caulfield
Modified: 2010-01-11 22:24 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:07:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs for all daemons (200.59 KB, application/x-gzip)
2006-08-29 08:37 EDT, Christine Caulfield
no flags Details

  None (edit)
Description Christine Caulfield 2006-08-29 08:37:38 EDT
Description of problem:

When attempting to mount a GFS2 filesystem I got the following error:
[root@bench-18 pcaulfie]# mount -tgfs2 /dev/vg/gfs2 /mnt/gfs
/sbin/mount.gfs2: error: jid is -2, try rw
/sbin/mount.gfs2: error mounting lockproto lock_dlm

Attempting to do it again gave this :
[root@bench-18 pcaulfie]# mount -tgfs2 /dev/vg/gfs2 /mnt/gfs
/sbin/mount.gfs2: lock_dlm_join: gfs_controld join error: -17
/sbin/mount.gfs2: error mounting lockproto lock_dlm


Version-Release number of selected component (if applicable):


How reproducible:
Not tried.


Additional info:
Logs for all daemons are attached
Comment 1 Christine Caulfield 2006-08-29 08:37:38 EDT
Created attachment 135121 [details]
Logs for all daemons
Comment 2 Christine Caulfield 2006-08-29 09:12:32 EDT
Looking at my filesystem afterwards it looks like it has got corrupted, which is
possibly the cause of the first error.

Even so, the error could have been more helpful. And consistent too - the second
error is completely different!
Comment 3 David Teigland 2006-08-29 11:09:36 EDT
Node 16 is withdrawing (probably as a result of the corrupted fs) and
that's where things are getting fouled up -- gfs_controld needs a fair
bit of testing and fixing in the area of withdraw.
Comment 4 Kiersten (Kerri) Anderson 2006-10-03 12:49:10 EDT
Devel ACK for RHEL 5
Comment 5 RHEL Product and Program Management 2006-10-03 13:11:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 6 David Teigland 2006-10-13 16:06:07 EDT
Bunch of gfs_controld changes checked in to handle various situations
in the areas of:
- recoveries mixed with mounts
- mounts failing while many nodes are mounting in parallel
Comment 8 Nate Straz 2007-12-13 12:42:38 EST
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.
Comment 9 Nate Straz 2007-12-19 15:06:44 EST
Moving all closed bugs to gfs-kmod to match the rpm name.  GFS-kernel will be
removed.

Note You need to log in before you can comment on or make changes to this bug.