Bug 204473 - [as_IN]Problem with Qt engine for Assamese -- Dependent vowels
[as_IN]Problem with Qt engine for Assamese -- Dependent vowels
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: i18n
Depends On:
Blocks: 209972
  Show dependency treegraph
 
Reported: 2006-08-29 08:55 EDT by Amitakhya Phukan
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-19 05:05:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tar gzipped file having two screenshots (177.90 KB, application/x-gzip)
2006-08-29 08:55 EDT, Amitakhya Phukan
no flags Details
Confirmation required (14.01 KB, image/png)
2006-09-14 06:56 EDT, Mayank Jain
no flags Details
Incorrect rendering with "ra", "ri" and "re" (23.84 KB, image/png)
2006-09-14 07:04 EDT, Mayank Jain
no flags Details
Teste (75.34 KB, image/png)
2007-05-19 05:04 EDT, A S Alam
no flags Details

  None (edit)
Description Amitakhya Phukan 2006-08-29 08:55:32 EDT
Description of problem:There is a problem with the dependent vowels. I am
attaching two screenshots in a tar gzipped file. The file combination.png shows
the rendering as it should have been. The file screenshot.png shows the
rendering as it appears.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Start KBabel and try to edit a po file in Assamese.
2. As soon as we type the dependent vowels  for characters specially 09F0 and
09F1, the problem starts.
3.
  
Actual results:Attached in file combination.png.


Expected results:


Additional info:
Comment 1 Amitakhya Phukan 2006-08-29 08:55:32 EDT
Created attachment 135124 [details]
tar gzipped file having two screenshots
Comment 2 Leon Ho 2006-08-29 22:07:11 EDT
Look like from the screenshot, you got it working in gedit. So it is a Qt
rendering engine problem. Reassigning to correct component first.
Comment 3 Ngo Than 2006-08-31 06:00:40 EDT
Could you please give exactly steps how i can reproduce this problem please?
Thanks
Comment 4 Amitakhya Phukan 2006-08-31 06:11:38 EDT
ok
first open kbabel..
then change to assamese phonetic keyboard.
press 'r' in the keyboard followed by 'a','i','e' etc. i mean write 'r''a',
'r''i' etc. compare it with the screenshots i have given. in gedit the problem
is not there, but in KBabel, i get the Wrong rendering (screenshot.png).
Comment 5 Ngo Than 2006-08-31 06:22:58 EDT
what is LANG using here? and which font package is needed to be installed?
Comment 8 Amitakhya Phukan 2006-08-31 07:11:29 EDT
the LANG is bn_IN.UTF-8

the font package used is fonts-bengali-2.0.1-1

the characters i am referring to are 09F0 and 09F1.

the combination keys are : 

09F0 or 09F1 +:
----------------
0985, 0986, 0987, 0988, 0989,
098A, 098B, 098F, 0990, 0993 and 0994

Please refer to the pics for the rendering as it should be and as it is rendered
at present. Should you require any other information, please revert back to me.
Comment 9 Ngo Than 2006-09-04 08:46:09 EDT
*** Bug 204738 has been marked as a duplicate of this bug. ***
Comment 10 Runa Bhattacharjee 2006-09-04 09:12:16 EDT
I'd like to clarify here that bn_IN (Bengali) and as_IN (Assamese) use the same
font package i.e. Lohit Bengali as the script used for both the languages are same.

There are however two differences:
# bn_IN consists of U+09B0 which is replaced by U+09F0 in as_IN locale to
represent the character "Ra".
# as_IN has an extra character U+09F1 which is *not* used in bn_IN

In the font package the U+09B0 character has been identified correctly and its
relationship with dependent vowels established. Unfortunately as U+09F0 and
U+09F1 was not tested earlier their relationship with dependent vowels have not
been identified.

This bug imho should not be considered as a duplicate of 204738 as it is a
completely different consonant U+09CE which is shared by both Bengali and Assamese.
Comment 11 Mayank Jain 2006-09-14 06:56:30 EDT
Created attachment 136248 [details]
Confirmation required

Hi,

The screenshots for gedit/kedit are attached.
The editor in background is Gedit & in frontend is Kedit.

Amitakhya, can you please confirm the status of this bug? Is the screenshot
attached by me, still shows the bug?

[majain@majain ~]$ rpm -q qt
qt-3.3.6-5
qt-3.3.6-13
[majain@majain ~]$ rpm -q kdebase
kdebase-3.5.4-6.fc6

Thanks,
Mayank
Comment 12 Mayank Jain 2006-09-14 07:04:14 EDT
Created attachment 136249 [details]
Incorrect rendering with "ra", "ri" and "re"

Oops!
The above screenshot was with "k" when steps to reproduce bug were using "r".

My fault... attaching the new incorrect rendering screenshot.
Comment 13 Sachin Tawniya 2006-11-06 07:52:41 EST
Please refere to bug #209972.
Patch has been submitted and can see the effect in latest Qt version.
Comment 14 A S Alam 2007-05-19 05:04:57 EDT
Created attachment 155043 [details]
Teste
Comment 15 A S Alam 2007-05-19 05:05:51 EDT
CLOSE, as mention issue was fixed

Note You need to log in before you can comment on or make changes to this bug.