Bug 204509 - lvm.static segfaults when trying to do initial vgscan in rc.sysinit with clustered LV's
lvm.static segfaults when trying to do initial vgscan in rc.sysinit with clus...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-29 13:15 EDT by Josef Bacik
Modified: 2007-11-16 20:14 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0287
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 20:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core from x86_64 lvm.static (848.00 KB, application/octet-stream)
2006-08-29 13:15 EDT, Josef Bacik
no flags Details

  None (edit)
Description Josef Bacik 2006-08-29 13:15:28 EDT
Description of problem:
My system has a local LV and clustered LV's.  On bootup when it's trying to do
the initial vgscan to activate any local LV's lvm.static will segfault.  If I go
back to the U3 version it does not segfault.

Version-Release number of selected component (if applicable):
2.02.06-6.0.RHEL4

How reproducible:
Every time

Steps to Reproduce:
1. Have a local FS on LVM
2. Have clustered LV's
3. Boot
  
Actual results:
lvm.static will segfault

Expected results:
it should not segfault

Additional info:
I got a core from the segfault.  I will look into this when I have more time,
but for now the bt is

[josef@dhcp59-136 ~]$ gdb /sbin/lvm.static core.2231 
GNU gdb Red Hat Linux (6.3.0.0-1.63rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...Using host libthread_db
library "/lib64/tls/libthread_db.so.1".

Core was generated by `lvm.static lvdisplay'.
Program terminated with signal 11, Segmentation fault.
#0  0x00000000004c936c in dl_open_worker ()
(gdb) bt
#0  0x00000000004c936c in dl_open_worker ()
#1  0x00000000004c7fc0 in _dl_catch_error ()
#2  0x00000000004c996c in _dl_open ()
#3  0x0000000000496b97 in dlopen_doit ()
#4  0x00000000004c7fc0 in _dl_catch_error ()
#5  0x0000000000496d76 in _dlerror_run ()
#6  0x0000000000496bbe in __dlopen ()
#7  0x00000000004455f5 in load_shared_library (cft=Variable "cft" is not available.
) at misc/sharedlib.c:50
#8  0x00000000004453a8 in init_external_locking (locking=0x64dee0, cft=0x6e33e0)
at locking/external_locking.c:75
#9  0x000000000042cd20 in init_locking (type=2, cft=0x6e33e0) at
locking/locking.c:144
#10 0x000000000040785a in _run_command (cmd=0x6d9a00, argc=Variable "argc" is
not available.
) at lvmcmdline.c:873
#11 0x00000000004088d8 in lvm2_main (argc=1, argv=0x7fbffffa90,
is_static=Variable "is_static" is not available.
) at lvmcmdline.c:1442
#12 0x0000000000476e21 in __libc_start_main ()
#13 0x000000000040018a in _start ()
#14 0x0000007fbffffa78 in ?? ()
#15 0x0000000000000000 in ?? ()

the core I'm uploading was made on an x86_64 machine.
Comment 1 Josef Bacik 2006-08-29 13:15:32 EDT
Created attachment 135155 [details]
core from x86_64 lvm.static
Comment 2 Alasdair Kergon 2006-08-29 13:57:27 EDT
Package versions please e.g. kernel, device-mapper, lvm2, lvm2-cluster
Comment 3 Alasdair Kergon 2006-08-29 14:00:08 EDT
and filesystem configuration (eg. copy of fstab)
Comment 4 Josef Bacik 2006-08-29 14:01:47 EDT
lvm2-cluster-2.02.06-7.0.RHEL4
device-mapper-1.02.07-4.0.RHEL4
lvm-2.02.06-6.0.RHEL4
kernel-smp-2.6.9-42.EL

[root@viper1 ~]# cat /etc/fstab 
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/myvg/homevol       /home                   ext3    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
LABEL=SWAP-sda6         swap                    swap    defaults        0 0
/dev/hda                /media/cdrecorder       auto    pamconsole,fscontext=sys
tem_u:object_r:removable_t,exec,noauto,managed 0 0
Comment 5 Josef Bacik 2006-08-29 18:38:00 EDT
Using locking_type=3 makes it so it does not segfault.
Comment 6 Josef Bacik 2006-08-29 18:39:20 EDT
btw it seems you can reproduce this panic easily while the system is running
with everything mounted.
Comment 11 Alasdair Kergon 2006-09-15 16:24:22 EDT

*** This bug has been marked as a duplicate of 204793 ***
Comment 13 Alasdair Kergon 2006-09-15 16:32:10 EDT
fixed in cvs - see bug 204793 - fix will get picked up in next build
Comment 20 Alasdair Kergon 2006-11-27 16:30:34 EST
There is a simple workaround in comment #5, so I see no point in doing a hotfix.
Comment 23 Alasdair Kergon 2007-01-30 09:35:58 EST
Fixed in RHEL4.5
Comment 28 Red Hat Bugzilla 2007-05-07 20:06:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0287.html
Comment 32 Issue Tracker 2007-06-26 14:45:14 EDT
Internal Status set to 'Resolved'
Status set to: Closed by Tech
Resolution set to: 'Security Errata'

This event sent from IssueTracker by sbradley 
 issue 103683

Note You need to log in before you can comment on or make changes to this bug.