Bug 204568 - Missing static libraries in devel package
Missing static libraries in devel package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: directfb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-29 21:20 EDT by Eric Moret
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 09:34:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes the issue (910 bytes, text/x-patch)
2006-08-29 21:20 EDT, Eric Moret
no flags Details
Spec file including static libraries (11.05 KB, application/octet-stream)
2007-01-16 14:28 EST, Eric Moret
no flags Details
sysfs patch (955 bytes, patch)
2007-01-16 18:46 EST, Eric Moret
no flags Details | Diff
Spec file including sysfs patch (11.11 KB, application/octet-stream)
2007-01-16 18:47 EST, Eric Moret
no flags Details

  None (edit)
Description Eric Moret 2006-08-29 21:20:26 EDT
From the description field, "The DirectFB-devel package contains the static
libraries and header files needed for development with DirectFB."

... except that the actual package does not provide them. I need the static
libraries to build splashy, a userspace bootsplash.

See attached patch to fix the issue.
Comment 1 Eric Moret 2006-08-29 21:20:26 EDT
Created attachment 135177 [details]
Patch that fixes the issue
Comment 2 Matthias Saou 2006-09-15 10:24:28 EDT
You really need the static library? Is it for the program to be contained in an
initrd or something like that? If that's the case, maybe it would make sense to
re-enable the static library in the package... still, it's wasted space for most
users.
Comment 3 Eric Moret 2006-09-15 11:19:43 EDT
Yes, it is needed to compile a program that will end up in initrd. Maybe we 
could create a subpackage containing only the static library so as to not waste 
space for other users?
Comment 4 Matthias Saou 2006-11-13 08:00:28 EST
Would fixing bug #186521 maybe solve your problem, by allowing you to link
dynamically to directfb? I haven't ever looked at splashy, so I really don't
know what's doable or not...
Comment 5 Eric Moret 2007-01-16 14:28:54 EST
Created attachment 145719 [details]
Spec file including static libraries
Comment 6 Eric Moret 2007-01-16 14:30:06 EST
I don't know if fixing bug #186521 would get splashy to compile but the attached
spec did fix it.
Comment 7 Eric Moret 2007-01-16 18:44:42 EST
Addind sysfs patch that fixes another splashy build issue
Comment 8 Eric Moret 2007-01-16 18:46:03 EST
Created attachment 145758 [details]
sysfs patch
Comment 9 Eric Moret 2007-01-16 18:47:22 EST
Created attachment 145760 [details]
Spec file including sysfs patch
Comment 10 Matthias Saou 2007-01-17 06:44:53 EST
Thanks a lot for this patch. I've just requested a build of the latest 1.0.0-rc2
for FC devel, could you please test once it is available and let me know if you
can rebuild spashy with it?
Comment 11 Eric Moret 2007-01-17 19:44:43 EST
Following the threat at bug #215537 regarding static libraries for libjpeg, I
asked the splashy devel team why they linked static. As it turns out their
upcoming 0.3 release compiles fine with dynamic libraries making that bug
request moot. Thanks goes to Tom Lane who was so reluctant to include static
libs and sorry for the confusion. I guess that bug could be closed with NOTABUG.
Comment 12 Matthias Saou 2007-02-02 09:34:29 EST
Well, closing as NOTABUG then :-)

Note You need to log in before you can comment on or make changes to this bug.