Bug 204578 - parted-1.7.1-15.fc5 breaks pyparted
Summary: parted-1.7.1-15.fc5 breaks pyparted
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: parted   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: Reopened
: 204580 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-30 06:26 UTC by David Juran
Modified: 2007-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version: pyparted-1.7.3-1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 13:37:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Juran 2006-08-30 06:26:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060808 Fedora/1.5.0.6-2.fc5 Firefox/1.5.0.6 pango-text

Description of problem:
The current pyparted in FC5 (pyparted-1.6.10-1.2.1) requires libparted-1.6.so.14 but the recent update of parted (parted-1.7.1-15.fc5) only provides libparted-1.7.so.1 so the update fails.

Version-Release number of selected component (if applicable):
parted-1.7.1-15.fc5

How reproducible:
Always


Steps to Reproduce:
1. yum upgrade


Actual Results:


Expected Results:


Additional info:

Comment 1 Bernhard Erdmann 2006-08-30 07:48:05 UTC
for me too

# yum -y update
Setting up Update Process
Setting up repositories
core                                                                 [1/6]
updates                                                              [2/6]
greysector-all                                                       [3/6]
greysector-all-noarch                                                [4/6]
greysector                                                           [5/6]
extras                                                               [6/6]
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package slang-devel.i386 0:2.0.6-1.fc5 set to be updated
---> Package parted.i386 0:1.7.1-15.fc5 set to be updated
---> Package slang.i386 0:2.0.6-1.fc5 set to be updated
---> Package parted-devel.i386 0:1.7.1-15.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libparted-1.6.so.14 for package: pyparted
--> Finished Dependency Resolution
Error: Missing Dependency: libparted-1.6.so.14 is needed by package pyparted


Comment 2 Sebastian Vahl 2006-08-30 08:45:13 UTC
gparted ist also affected:

--> Populating transaction set with selected packages. Please wait.
---> Package parted.i386 0:1.7.1-15.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libparted-1.6.so.14 for package: pyparted
--> Processing Dependency: libparted-1.6.so.14 for package: gparted
--> Finished Dependency Resolution
Error: Missing Dependency: libparted-1.6.so.14 is needed by package pyparted
Error: Missing Dependency: libparted-1.6.so.14 is needed by package gparted

Comment 3 Konstantin Antselovich 2006-08-30 09:40:48 UTC
confirm the same here:

sudo yum --disablerepo=skype update parted
...
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package parted.i386 0:1.7.1-15.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libparted-1.6.so.14 for package: pyparted
--> Finished Dependency Resolution
Error: Missing Dependency: libparted-1.6.so.14 is needed by package pyparted


Comment 4 Jim Cornette 2006-08-30 10:35:09 UTC
I had the same error when trying to update programs. I am running the
updates-testing repo also,

Comment 5 Peter E. Popovich 2006-08-30 11:08:58 UTC
Recommend marking this a duplicate of Bug 204580.  Both bugs describe the same
issue, but that one was filed as a bug in pyparted, not in parted.

Given a glance at the rawhide changelog for pyparted, I'm guessing the fix here
is to push pyparted-1.7.1-1.1 to updates.

Comment 6 David Cantrell 2006-08-30 14:41:33 UTC
Oh, right.  My bad.  I also own pyparted and forgot to rebuild.  Doing so now.

Comment 7 David Cantrell 2006-08-30 15:45:26 UTC
*** Bug 204580 has been marked as a duplicate of this bug. ***

Comment 8 Zack Cerza 2006-08-30 16:22:47 UTC
gparted also needs a rebuild. That's in Extras, so should this bug be cloned
against it?

Comment 9 David Cantrell 2006-08-30 17:12:46 UTC
Feel free.  I don't own anything in Extras.  If I did, I'd rebuild it.

Comment 10 Peter E. Popovich 2006-08-30 17:16:56 UTC
Several folks have asked for rebuilds of gparted -> Bug 204581 and it's duplicates.

Comment 11 Joe Buck 2006-08-31 04:54:35 UTC
Is there a methodology issue here?  'twould be nice if, when submitting a
proposed update, something automatically flags reverse-depends that will become
uninstallable (if any).  The Debian testing script performs this check before
accepting packages from unstable, though apparently it requires a baby-sitter at
times to get collections of interdependent packages through.

See http://bjorn.haxx.se/debian/



Comment 12 Alex Lancaster 2006-08-31 10:23:45 UTC
This is very bad that a regular upgrade would break Core so badly.  Surely this
should have been picked up by the build system or in updates-testing...  And
it's been like this for a couple of days!!

This also breaks upgrade for hwbrowser and anaconda:

$ sudo smart upgrade
Password:
Loading cache...
Updating cache...               ######################################## [100%]

Computing transaction...

Upgrading packages (5):
  anacron-2.3-39.fc5@i386                slang-2.0.6-1.fc5@i386
  parted-1.7.1-15.fc5@i386               slang-devel-2.0.6-1.fc5@i386
  php-pear-1:1.4.9-1.2@noarch

Removing packages (4):
  anaconda-11.0.5-1@i386                 hwbrowser-0.26-1@noarch
  anaconda-runtime-11.0.5-1@i386         pyparted-1.6.10-1.2.1@i386

1.8MB of package files are needed. 16.3MB will be freed.

Confirm changes? (Y/n): n


Comment 13 Jim Cornette 2006-08-31 10:50:14 UTC
The update today (8/31/2006) fixes the problem with core. The updates were
successful. Regarding the effects on Fedora-Extras, I'm not sure about the
graphical parted front-end program.

Comment 14 Alex Lancaster 2006-08-31 11:28:41 UTC
(In reply to comment #13)
> The update today (8/31/2006) fixes the problem with core. The updates were
> successful. 

This must be with updates-testing.  There is no new pyparted in updates.

Comment 15 David Cantrell 2006-08-31 13:42:22 UTC
(In reply to comment #11)
> Is there a methodology issue here?  'twould be nice if, when submitting a
> proposed update, something automatically flags reverse-depends that will become
> uninstallable (if any).  The Debian testing script performs this check before
> accepting packages from unstable, though apparently it requires a baby-sitter at
> times to get collections of interdependent packages through.
> 
> See http://bjorn.haxx.se/debian/
> 
> 


You're right.  I own both the parted and pyparted packages and I should have
remembered to rebuild both.  It was an oversight on my part.  We do have a
really nice Fedora Updates system where you submit proposed updates and they go
through rel-eng.  They check to make sure they can install and such.  This one
made it through for some reason.

But I've moved pyparted to updates-final now.

Comment 16 Alex Lancaster 2006-09-01 02:32:12 UTC
What is usual time lag for updates being available after they are pushed? 
Haven't yet seen the new pyparted in:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/i386/

Comment 17 David Juran 2006-09-01 09:59:15 UTC
Seems like pyparted didn't quite go through the build system...



Comment 18 David Cantrell 2006-09-01 12:47:57 UTC
Yes, it did.  It's sitting in
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/5/i386

I will be getting releng to move both the mkinitrd and pyparted I did for FC5
over to final updates.


Note You need to log in before you can comment on or make changes to this bug.