Bug 204619 - Borked color palette upon resume for SuperSavage IX/C
Summary: Borked color palette upon resume for SuperSavage IX/C
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-30 13:56 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 19:27:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2006-08-30 13:56:46 UTC
Description of problem:
After resuming from suspend and restarting the "X" server, the color
palette is borked. The color scheme looks "psychedelic" with vivid
colors. One has to reboot the system to obtain a usable desktop.
The system is an "IBM ThinkPad T23" sporting a "SuperSavage IX/C"
chip and 16 MB of video memory.

Version-Release number of selected component (if applicable):
xorg-x11-drv-savage-2.1.1-5.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Suspend to memory.
2. Resume fron supend.
3. Logout from "GNOME" session.
  
Actual results:
Login screen is rendered using crazy colors.

Expected results:
Login screen is rendered normally.

Additional info:
The color palette is still hosed after logging in to a "GNOME" session.
The issue is restricted to 24 bpp mode. Setting the default color depth
to 16 bpp makes it disappear.

Comment 1 Joachim Frieben 2006-11-12 19:27:24 UTC
Probably a kernel or "X" server issue, as it has been settled without
a driver update.


Note You need to log in before you can comment on or make changes to this bug.