Bug 204627 - The qla2400 driver is not automatically loaded for the QLE2460.
The qla2400 driver is not automatically loaded for the QLE2460.
Status: CLOSED DUPLICATE of bug 202267
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: hwdata (Show other bugs)
4.4
All Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
: 207299 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-30 10:49 EDT by Wayne Berthiaume
Modified: 2015-03-04 20:17 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 10:25:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
System details, lspci output, etc. (10.43 KB, text/plain)
2006-08-30 10:49 EDT, Wayne Berthiaume
no flags Details
Output from kudu -p. (3.66 KB, text/plain)
2006-09-06 11:01 EDT, Wayne Berthiaume
no flags Details

  None (edit)
Description Wayne Berthiaume 2006-08-30 10:49:23 EDT
Description of problem:
The qla2400 and qla2xxx drivers are not automatically loaded for the QLE2460 on 
a fresh install of RHEL 4.4. There are no entries in /etc/modprobe.conf so the 
driver is not in the initrd image.

Version-Release number of selected component (if applicable):
RHEL 4.4 (2.6.9-42.ELsmp)

How reproducible:
Always

Steps to Reproduce:
1.Perform a fresh install on any server with a QLE2460 installed
2.Reboot the new server
3.
  
Actual results:
The driver is not loaded for the QLE2460.

Expected results:
The driver should automatically be loaded on boot.

Additional info:
Comment 1 Wayne Berthiaume 2006-08-30 10:49:23 EDT
Created attachment 135211 [details]
System details, lspci output, etc.
Comment 2 Tom Coughlan 2006-08-30 11:27:06 EDT
modules.pcimap has:

qla2400              0x00001077 0x00002432 0xffffffff 0xffffffff 0x00000000 0x00

and lspci -n shows 

22:00.0 Class 0c04: 1077:2432 (rev 02)
        Subsystem: 1077:0138

but the qla2400 module does not get loaded. RHEL 4.4.

Bill, can you let us know what the problem is? 
Comment 3 Bill Nottingham 2006-08-30 12:03:52 EDT
Nothing obvious comes to mind. It isn't loaded on boot either?

Can you attach the output of 'kudzu -p'?
Comment 4 ravi anand 2006-08-30 17:43:44 EDT
It seems to me that "pcitable" file does not include the "2432:qla2400"
mapping ie "device_id:driver_name".  

If thats the case then we need to make sure that all the latest QLogic ISP
products device id including 4gb is folded in.

The pci-ids repository has been updated. Here's the link :

http://pci-ids.ucw.cz/iii/?i=1077

Thanx
Ravi Anand
Comment 5 Bill Nottingham 2006-08-31 12:22:28 EDT
PCI table is irrelevant in this case.
Comment 6 Andrius Benokraitis 2006-09-05 14:39:22 EDT
Wayne, any more updates on this issue?
Comment 7 Wayne Berthiaume 2006-09-06 11:01:20 EDT
Created attachment 135657 [details]
Output from kudu -p.

Attached is the output from "kudzu -p". It shows that kudzu() has selected the
qla2322 driver. Included in the kudzu.txt file is the current lspci() output
and the modules.pcimap from the test server as well.
Comment 8 Bill Nottingham 2006-09-06 13:33:18 EDT
pcitable is out of date. The entries should probably just be removed. Did
qla2322 ever drive this card?
Comment 9 Andrew Vasquez 2006-09-06 13:37:40 EDT
No -- the qla2322.ko module never contained a pci_device_id entry
for the 2432 card.
Comment 10 Wayne Berthiaume 2006-09-07 09:16:54 EDT
If I've read the pcitable correctly it should have selected the qla2400.ko 
module which would have been correct. Am I correct?

06:01.1 Fibre Channel: QLogic Corp. _QLA2422_ Fibre Channel Adapter (rev 02)

root #> grep -i qla modules.pcimap

qla2400              0x00001077 _0x00002422_ 0xffffffff 0xffffffff 0x00000000 
0x00000000 0x0
Comment 11 Bill Nottingham 2006-09-07 10:17:22 EDT
That file is overriden by /usr/share/hwdata/pcitable (the legacy file) which is
(apparently) out of date/broken.
Comment 12 Phil Knirsch 2006-09-07 10:25:26 EDT

*** This bug has been marked as a duplicate of 202267 ***
Comment 13 Tom Coughlan 2006-10-06 14:20:14 EDT
*** Bug 207299 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.