Bug 204636 - Recent update to parted breaks if qtparted is installed
Recent update to parted breaks if qtparted is installed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qtparted (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-30 11:29 EDT by Kevin J. Cummings
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.4.5-9.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 12:25:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin J. Cummings 2006-08-30 11:29:55 EDT
Description of problem:
The current release of qtparted is explicitly dependant upon libparted-1.6.so.4.
The recent update of parted-1.7.1-15.fc5 changes this library to
libparted-1.7.so.1.0.0 which breaks the update if qtparted is installed.

Version-Release number of selected component (if applicable):
0.4.5-4.fc5 

How reproducible:
run yum update



Steps to Reproduce:
1. yum update parted
2.
3.
  
Actual results:
# yum update parted
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading "kmdl" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/7]
livna                     100% |=========================|  951 B    00:00     
skype                                                                [2/7]
skype                     100% |=========================|  951 B    00:00     
core                                                                 [3/7]
core                      100% |=========================| 1.1 kB    00:00     
updates                                                              [4/7]
updates                   100% |=========================| 1.2 kB    00:00     
freshrpms                                                            [5/7]
freshrpms                 100% |=========================|  951 B    00:00     
macromedia                                                           [6/7]
macromedia                100% |=========================|  951 B    00:00     
extras                                                               [7/7]
extras                    100% |=========================| 1.1 kB    00:00     
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.4 MB    00:02     
extras    : ################################################## 4762/4762
Added 131 new packages, deleted 95 old in 10.17 seconds
Excluding Packages from Livna for Fedora Core 5 - i386 - Base
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for parted to pack into transaction set.
parted-1.7.1-15.fc5.i386. 100% |=========================|  24 kB    00:00     
---> Package parted.i386 0:1.7.1-15.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libparted-1.6.so.14 for package: pyparted
--> Processing Dependency: libparted-1.6.so.14 for package: gparted
--> Processing Dependency: libparted-1.6.so.14 for package: qtparted
--> Finished Dependency Resolution
Error: Missing Dependency: libparted-1.6.so.14 is needed by package pyparted
Error: Missing Dependency: libparted-1.6.so.14 is needed by package gparted
Error: Missing Dependency: libparted-1.6.so.14 is needed by package qtparted


Expected results:

Expected yum to find an update for qtparted to update as well.

Additional info:
Comment 1 Kasper Dupont 2006-08-30 14:13:36 EDT
Fails also without qparted installed. I get the following when trying to update:

[root@localhost:pts/3:~] yum update       
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
updates                                                              [1/4]
updates                   100% |=========================| 1.2 kB    00:00     
core                                                                 [2/4]
core                      100% |=========================| 1.1 kB    00:00     
freshrpms                                                            [3/4]
freshrpms                 100% |=========================|  951 B    00:00     
extras                                                               [4/4]
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package parted.i386 0:1.7.1-15.fc5 set to be updated
---> Package vixie-cron.i386 4:4.1-56.fc5 set to be updated
---> Package kdebase.i386 6:3.5.4-0.4.fc5 set to be updated
---> Package cscope.i386 0:15.5-15.fc5.1 set to be updated
---> Package udev.i386 0:084-13.fc5.2 set to be updated
---> Package coreutils.i386 0:5.97-1.2 set to be updated
---> Package kdebase-devel.i386 6:3.5.4-0.4.fc5 set to be updated
---> Package curl.i386 0:7.15.5-1.fc5 set to be updated
---> Package slang.i386 0:2.0.6-1.fc5 set to be updated
---> Package selinux-policy.noarch 0:2.3.7-2.fc5 set to be updated
---> Package curl-devel.i386 0:7.15.5-1.fc5 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.3.7-2.fc5 set to be updated
---> Package parted-devel.i386 0:1.7.1-15.fc5 set to be updated
---> Package tcsh.i386 0:6.14-6.fc5.3 set to be updated
---> Package eject.i386 0:2.1.5-0.2.fc5 set to be updated
---> Package slang-devel.i386 0:2.0.6-1.fc5 set to be updated
---> Package libquicktime.i386 0:0.9.10-1.fc5 set to be updated
---> Package php-pear.noarch 1:1.4.9-1.2 set to be updated
---> Package selinux-policy-strict.noarch 0:2.3.7-2.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libparted-1.6.so.14 for package: pyparted
--> Finished Dependency Resolution
Error: Missing Dependency: libparted-1.6.so.14 is needed by package pyparted
[root@localhost:pts/3:~] 
Comment 2 Steven Pritchard 2006-08-30 14:40:49 EDT
Sorry, I didn't have any warning for this incompatible library change.

The Extras build systems are down today, so I won't be able to rebuild qtparted
until late tonight, at the earliest.
Comment 3 Steven Pritchard 2006-08-31 12:25:57 EDT
qtparted 0.4.5-9.fc5 should be on its way to mirrors now.

Note You need to log in before you can comment on or make changes to this bug.