Bug 204647 - ClassCastException on Errata Packages page
ClassCastException on Errata Packages page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn420
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan Newberry
Preethi Thomas
:
Depends On:
Blocks: 146933
  Show dependency treegraph
 
Reported: 2006-08-30 12:05 EDT by Ken Ganong
Modified: 2013-08-05 23:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: 420
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 11:54:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2006-08-30 12:05:22 EDT
Reproduction:
1. Go to Errata -> Select an Errata -> Packages

Expected Results:
A list of Packages.

Actual Results:
ClassCastException
Caused by: java.lang.ClassCastException:
com.redhat.rhn.frontend.dto.ErrataPackageFile
        at
com.redhat.rhn.frontend.action.errata.ErrataPackagesSetupAction.execute(ErrataPackagesSetupAction.java:54)

Expected Results:
Packages page.

Additional notes:
bug occurs in 420 branch.  Not reproducible on webdev.
Comment 1 Ryan Newberry 2006-08-30 12:27:52 EDT
This bug also occurs in 415. Moving it to the 415 errata bug tracker.
Comment 2 Ryan Newberry 2006-08-30 12:37:16 EDT
Fix is in 415 and 420 as of revision 101465
Comment 3 Ryan Newberry 2006-08-30 13:15:48 EDT
This is, in fact, not a 415 bug after all. Undid the changes in 415 and a REAL
fix was committed to 420 as of revision 101474.
Comment 4 Preethi Thomas 2007-01-17 09:03:11 EST
verified. QAPush#5
Comment 5 Preethi Thomas 2007-03-07 12:33:57 EST
verified in stage.

Note You need to log in before you can comment on or make changes to this bug.