Bug 204657 - scim-bridge outputting IOException from gvim
scim-bridge outputting IOException from gvim
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
: 208664 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-30 13:17 EDT by charles harris
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 03:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description charles harris 2006-08-30 13:17:03 EDT
Description of problem:

I get the following message group when running gvim from a terminal:

Failed to send a message at scim_bridge_client_set_preedit_mode ()
An IOException occurred at scim_bridge_client_imcontext_set_preedit_enabled ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_set_preedit_mode ()
An IOException occurred at scim_bridge_client_imcontext_set_preedit_enabled ()
An IOException at scim_bridge_messenger_send_message (): Broken pipe


Version-Release number of selected component (if applicable):

scim-bridge-gtkimm-0.4.1-1.fc6
scim-bridge-0.4.1-1.fc6

How reproducible:

Sporadic. I am not sure what actions in gvim trigger the messages.

Steps to Reproduce:
1. Start gvim in terminal.
2. Edit text.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 charles harris 2006-08-30 18:41:19 EDT
Happens when I start up a new edit session and first hit i to insert text.
Comment 2 Jens Petersen 2006-08-30 22:40:32 EDT
Thanks for the report.  This seems to be different from bug 204118:
I reproduced it too.
Comment 3 Ryo Dairiki 2006-08-31 03:15:04 EDT
Thanks, I've fixed that on the CVS latest.
Comment 4 Jens Petersen 2006-09-01 04:51:41 EDT
Thank you: updating to 0.4.2 which should include the fix. :)
Comment 5 Xiaohong Wang 2006-09-29 03:15:49 EDT
Verified that it has been fixed in latest FC6:
# rpm -q scim-bridge
scim-bridge-0.4.5-2.fc6 
Comment 6 Jens Petersen 2006-09-30 00:05:37 EDT
*** Bug 208664 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.