Bug 204659 - add oval support to backend code
add oval support to backend code
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn415
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
:
Depends On:
Blocks: 201891
  Show dependency treegraph
 
Reported: 2006-08-30 13:40 EDT by Pradeep Kilambi
Modified: 2007-04-18 13:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHN415
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 15:55:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2006-08-30 13:40:13 EDT
Description of problem:
Add capability to handle oval file support to the backend importlib code.
Basically errata-tool will send the oval-meta data in an xml-rpc call along with
the erratum. On the backend side we need to create an oval 'xml' file from the
metadata and put it on the filesystem. Then fill the erratum with relevant data
for the info to be populated into the db.

Steps to implement:
1. modify errata-tool to get oval info through an xml-rpc call.
2. add capability to backend to read the oval metadata and generate oval xml
files by filling an oval template and dump it on RHN filesystem.
3. change the backend code to populate the db with relevant data along with the
erratum info and hand it of to put on the webui.

the step #2 is ok for hosted. But if we want to worry about satellite support as
well, it would be more flexible if we could embed the xml data directly into the
db. That way sat-sync will not have to be changed later( this is still not big
concern for 415 timeframe as its going to be a hosted only release.)

Expected results:
handle oval info sent through the errata-tool and populate the db with the
revelant info for webui to access it.
Comment 1 Pradeep Kilambi 2006-08-30 13:46:52 EDT
The basic functionality is in place. 

- created a dummy erratum with oval metadata

- modified backend to grab the oval metadata from erratum and generate oval xml
files and dumps them on a specified mount point.

- modified importlib to get the file info for the xml on FS and munge it to
populate the oval info along with the rest of the erratum.

Comment 2 Brandon Perkins 2006-10-10 10:46:01 EDT
Verified.  Basic functionality works.  Individual bugs will be entered for
specific issues.
Comment 3 Beth Nackashi 2006-10-26 14:17:39 EDT
moving from VERIFIED to RELEASE_PENDING since stage push is complete
Comment 4 Brandon Perkins 2006-11-09 15:55:28 EST
closing -- current release.  RHN415 is now in production.

Note You need to log in before you can comment on or make changes to this bug.