Bug 204662 - Emacs does not build on ix86 systems (segfaults in %install)
Emacs does not build on ix86 systems (segfaults in %install)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: emacs (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-30 14:08 EDT by Jos Vos
Modified: 2015-01-07 19:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:41:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2006-08-30 14:08:53 EDT
Description of problem:
Revival of #187884: emacs does not build on ix86 systems due to segfaults.  It
works ok in %build, but it crashes in %install.

Version-Release number of selected component (if applicable):
21.3-4.10

Description:
The %__make's in the %install section (2x) should be $__MAKE (as in %build) and
$__MAKE should be defined in %install as in %build.
Comment 1 Chip Coldwell 2006-11-02 14:47:42 EST
(In reply to comment #0)
> Description of problem:
> Revival of #187884: emacs does not build on ix86 systems due to segfaults.

Bug #187884 doesn't have anything to do with emacs or building!?

> It works ok in %build, but it crashes in %install.

I am not able to reproduce the problem.  I just ran it through our build system,
and did an "rpmbuild --rebuild emacs-21.3-4.10.src.rpm" on a RHEL-3 U5 system
and it worked with no problems.  What is your build platform?

Chip
Comment 2 RHEL Product and Program Management 2007-10-19 14:41:30 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.