Bug 20468 - can't export fs to multiple hosts
can't export fs to multiple hosts
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nfs-server (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 09:30 EST by hulst
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-17 03:57:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hulst 2000-11-07 09:30:21 EST
Hi,
On my old server (RH6.2) I had an entry in /etc/exports reading 
/usr/src	194.171.176.0/255.255.255.128(ro)

On the new RH7 this 'whole domain export' doesn't seem to work anymore. My
users get a 'permission denied' error, and/or then their 'normal' mounts to
their homedirectories go 'stale'. I tried 
/usr/src	*.argoss.nl(ro)
but that didn't do the trick either. When I speciffically declare every
host which may access the nfs volume, it works fine.

Sometimes the client (RH6.2) was able to mount his home directory and a
'all users' volume, but after a few minutes the mount would become stale
again. I think it is the rcp.nfsd or rpc.mountd (but then again, it doesn't
mean much what I think about that).

Hope this helps. Luckily we're not a big compagny, but I like neat
solutions.

Sander Hulst
ARGOSS BV
Netherlands
Comment 1 Alexandre Oliva 2001-01-16 13:22:40 EST
It works for me.  In a network at the university, I export to:
	*.lsd.ic.unicamp.br(rw)
and it works just fine.

Maybe it's some problem with reverse DNS, that causes the NFS server to reject
the mount?  Do you have any messages about rejected mounts in /var/log/messages?
Comment 2 hulst 2001-01-17 03:56:58 EST
The server deepserv9.argoss.nl:
[root@deepserv9 /etc]# exportfs
/home/argoss    *.argoss.nl
It is exported (rw)

The client geosat.argoss.nl:
[root@geosat deepserv9]#  mount deepserv9:/home/argoss argoss
mount: deepserv9:/home/argoss failed, reason given by server: Permission denied

/var/log/messages of server mumbles:
Jan 17 08:46:18 deepserv9 rpc.mountd: refused mount request from geosat for 
/home/argoss (/): no export entry
Comment 3 hulst 2001-01-17 04:20:40 EST
Err,
I found what the problem was. Mr Johnson mentioned reverse DNS, and that started
me thinking about the way the client identified itself on a server and what the
server did with that. A client identifies itself by IP, whereafter the server
resolves it in the order configured in host.conf. And there is the difference
between my old situation and the new one. On my old server I resolve with DNS,
my new first looks in /etc/hosts wherein I have put hostnames without the
argoss.nl part. So, nfs, who has an export for *.argoss.nl resolves the IP of my
computer and finds geosat instead of geosat.argoss.nl. No match, error.

Apologies for the inconvinience and thanks for all the fish :-)
(Hitchhikers Guide to the Galaxy)
Comment 4 hulst 2001-01-19 06:53:55 EST
Hi,
I fiddled some more with this, and I found out a strange thing. Because of the
theory I mentioned above I've set my resolving order to bind only. But as it
seems, the NFS server still checks the host first, regardless of what is set in
/etc/host.conf. I'm sure of this, because when I set my hostname alone in the
/etc/hosts file, a mount request fails, but when I either put my host name +
domain in /etc/hosts or totaly remove the entry, it works. The latter tells that
it does check bind, but after the hosts file.

Should we call it a bug or a nasty habbit?

Note You need to log in before you can comment on or make changes to this bug.