Bug 204709 - subdirs on dovecot server are not shown properly
Summary: subdirs on dovecot server are not shown properly
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: squirrelmail (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-30 23:00 UTC by Gianluca Sforna
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-30 15:25:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current dovecot configuration (20.00 KB, application/octet-stream)
2006-10-13 14:39 UTC, Gianluca Sforna
no flags Details

Description Gianluca Sforna 2006-08-30 23:00:04 UTC
Description of problem:
When using squirrelmail with a dovecot server, subdirectories are shown as:

dir1.dir2

instead of a proper tree. 


Additional info:
I dropped in my /etc/squirrelmail/config_local.php the lines:

$imap_server_type = 'courier';
$optional_delimiter = '.';


and this fixes the problem

Comment 1 Tomas 2006-10-13 13:34:17 UTC
show your dovecot namespace configuration.

please stop using configuration overrides and use standard configuration file
instead.

Comment 2 Gianluca Sforna 2006-10-13 14:38:46 UTC
I am not using namespaces (AFAIK the version I am using, dovecot-0.99.11-4.EL4,
does not even support them).

The problem is just the delimiter, and the configuration override is used just
to cope with this problem.

I am attaching my dovecot.conf file

one last note: it is always hard to judge a person from a 2 lines reply. Mind
you, I did not like the attitude of your comment

Comment 3 Gianluca Sforna 2006-10-13 14:39:50 UTC
Created attachment 138442 [details]
current dovecot configuration

Comment 4 Tomas 2006-10-21 17:39:40 UTC
Standard SquirrelMail 1.4.8 uses 

imap_server_type = dovecot
default_folder_prefix = <none> (is set to empty string)
trash_folder = Trash
sent_folder = Sent
draft_folder = Drafts
show_prefix_option = false
default_sub_of_inbox = false
show_contain_subfolders_option = false
optional_delimiter = detect
delete_folder = false
force_username_lowercase = true

preset for dovecot. You can set it with D menu option in SquirrelMail
configuration. config_local.php file should be used only for additional options
that can't be set in conf.pl. Fedora uses it to override standard configuration
and it breaks presets of some servers.

Similar issue is already reported upstream.
http://sourceforge.net/tracker/index.php?func=detail&aid=1353394&group_id=311&atid=423679

Sorry if my response insulted you, but I've only asked to provide more
information about your setup, because dovecot 1.0 provides wide namespace
configuration options and your initial report does not say anything about used
version.

Comment 5 Gianluca Sforna 2006-10-22 21:33:31 UTC
(In reply to comment #4)
> Standard SquirrelMail 1.4.8 uses 
> 
> imap_server_type = dovecot
> default_folder_prefix = <none> (is set to empty string)
> trash_folder = Trash
> sent_folder = Sent
> draft_folder = Drafts
> show_prefix_option = false
> default_sub_of_inbox = false
> show_contain_subfolders_option = false
> optional_delimiter = detect
> delete_folder = false
> force_username_lowercase = true
> 
> preset for dovecot. You can set it with D menu option in SquirrelMail
> configuration. config_local.php file should be used only for additional options
> that can't be set in conf.pl. Fedora uses it to override standard configuration
> and it breaks presets of some servers.

Thanks for pointing this out.
I just noticed the dovecot specific config: AFAICS it was introduced in 1.4.6,
but my server was installed with an older version and the hack come from that.

I just dropped the hack, updated the config and the webmail works as expected.


> Sorry if my response insulted you, but I've only asked to provide more
> information about your setup, because dovecot 1.0 provides wide namespace
> configuration options and your initial report does not say anything about used
> version.

Ok. Then sorry for the incomplete report, and for wasting your time. 

Case (and bug :) ) closed...


Note You need to log in before you can comment on or make changes to this bug.