Bug 204722 - Version 0.9.8.3 not allowing login
Version 0.9.8.3 not allowing login
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: phpldapadmin (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 02:43 EDT by Kurt Heine
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 07:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Heine 2006-08-31 02:43:24 EDT
Description of problem:
The current version 0.9.8.3-1.fc5 does not seem to allow login.

Version-Release number of selected component (if applicable):
phpldapadmin-0.9.8.3-1.fc5
php-5.1.4-1
php-ldap-5.1.4-1
openldap-2.3.19-4
openldap-servers-2.3.19-4

How reproducible:
Install phpldapadmin running using php v5.1.4 and try to login and it 

Steps to Reproduce:
1. Go to web page
2. Click on the login link
3. Try to login using credentials
  
Actual results:
Get a message :
Error bad username or password.

Expected results:
Login using the ldap admin user and acccess the ldap.

Additional info:
If I upgrade and manually use the phpldapadmin-1.0.1 version which seems to be
made for the php v5 then it all works with no problems.
Comment 1 Dmitry Butskoy 2006-08-31 07:39:26 EDT
> 3. Try to login using credentials
What exactly is your "login" string? Is it an uid or a full dn?

What is your "login attr" definition in /etc/phpldapadmin/config.php ?

By default, "uid" login attr is used for Fedora, whereas upstream can use "dn"
for this. If you try to login using something like "cn=admin,dc=example,dc=com"
(i.e. without any "uid"), and the login attr is specified to be uid, then such a
login is surely impossible. Try "dn" instead of "uid" for "login attr" in
/etc/phpldapadmin/config.php

Comment 2 Kurt Heine 2006-08-31 22:55:09 EDT
(In reply to comment #1)
> > 3. Try to login using credentials
> What exactly is your "login" string? Is it an uid or a full dn?
> 

I am using the full dn string ("cn=admin,dc=example,dc=com") to login.

> What is your "login attr" definition in /etc/phpldapadmin/config.php ?
> 

I am using the default from the installed package.

> By default, "uid" login attr is used for Fedora, whereas upstream can use "dn"
> for this. If you try to login using something like "cn=admin,dc=example,dc=com"
> (i.e. without any "uid"), and the login attr is specified to be uid, then such a
> login is surely impossible. Try "dn" instead of "uid" for "login attr" in
> /etc/phpldapadmin/config.php
> 

I have changed it back to I guess the package creators defaults and it seems to
be working fine.

$ldapservers->SetValue($i,'login','attr','dn');
//$ldapservers->SetValue($i,'login','attr','uid');

Anyhow this seems to have fixed the problem and I can now login using the dn.


Note You need to log in before you can comment on or make changes to this bug.