Bug 204732 - GDM attempts to respawn on :0 after KDE indirect xdmcp session
GDM attempts to respawn on :0 after KDE indirect xdmcp session
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 07:12 EDT by Jason Cross
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 17:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Cross 2006-08-31 07:12:41 EDT
Description of problem:
I setup GDM to allow XDMCP connections over TCP.  I configured a chooser server
to query the system with GDM.  I can select the system running GDM in the
chooser, log in okay using KDE, and then logout.  I am then presented with the
chooser again.  On the system running GDM, GDM appears to restart and tries to
start an X server on :0.  This fails since there is already an X server running
on :0.  On the local console :0 is switched to a different virtual terminal with
the error:
There already appears to be an X server running on display :0.  Should another
display number by tried?  Answering no will cause GDM to attempt starting the
server on :0 again.  (You can change consoles by pressing Ctrl-Alt plus a
function key, such as Ctrl-Alt-F7 to go to console 7.  X servers usually run on
consoles 7 and higher.

If I select no, it tries to start a server on :0 again and fails with the same
message.  I say yes an X server starts up and attaches to :1.

I cannot reproduce this behavior if I login to a GNOME, fluxbox, window maker,
or failsafe session.

If I login to a failsafe session with just a terminal.  Run startkde, wait for
kde to start, then logout, then type exit in the terminal, I get the same
behavior where GDM tries to start on :0.

Version-Release number of selected component (if applicable): gdm-2.14.9-1


How reproducible:
Always.

Steps to Reproduce:
1.  Setup GDM to allow xmdcp connections of TCP.
2.  Do an indirect connection to a chooser, then select the host running GDM.
3.  Login to system with a KDE session.  Log out.
  
Actual results:
GDM tries to start a X server on :0 after closing a KDE session initiated
through indirect xdmcp.

Expected results:
GDM should not try to create any local console displays and should wait for more
xdmcp connections.
Comment 1 Charles Dennett 2007-05-21 10:15:28 EDT
I have a similar problem with RedHat EL5.  Using Hummingbird Exceed on my
Windows PC I use it with XDMCP to create a remote desktop from the Linux system
and display it on my PC.  When I log off the remote desktop, the Linux system
tried to start another X server on the console (:0).  This has been reported to
RedHat but so far they have been unable to recreate the problem.  

This problem did not occur with RedHat EL4.  It only started after an upgrade to
EL5.  Originally had Exceed version 7 on my PC.  I had our IT department upgrade
it to version 12 (the latest, I believe) to see if that would fix the problem. 
it did not.
Comment 2 ritz 2007-10-15 16:04:30 EDT
upstream bugzilla # http://bugzilla.gnome.org/show_bug.cgi?id=352838
patch attached to bugzilla works for me on RHEL5, afaik.

Comment 3 Jason Cross 2007-10-15 17:15:04 EDT
It does appear that the upstream bug is probably related to the problem I was 
having.  I moved from FC5 to F7 a while ago on my systems, and becuase of this 
bug also moved from indirect XDMCP to DNS round-robin load balancing to 
FreeNX.  Since this bug was reported for FC5 which I'm pretty sure is out of 
maintenance, it as as well be closed.

Note You need to log in before you can comment on or make changes to this bug.