Bug 204774 - nocpulse user isn't created on install if user with UID 502 exists
Summary: nocpulse user isn't created on install if user with UID 502 exists
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer   
(Show other bugs)
Version: 410
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 135141 158643
TreeView+ depends on / blocked
 
Reported: 2006-08-31 14:33 UTC by Justin Sherrill
Modified: 2008-04-03 17:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 17:06:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Sherrill 2006-08-31 14:33:45 UTC
Description of problem:

The NPusers rpm install script specifies a userid of 502 when creating the
NOCpulse user.  This will cause problems if the system already has a user
defined with uid of 502.  Since normal users get created with uids starting at
500, it isn't hard to see that this could become a problem.  If a UID must be
specified for the install script to work (for some reason), it would make sense
to use a much higher or lower uid.  

Version-Release number of selected component (if applicable): 410.  (Untested on
pre-410)



Steps to Reproduce:
1.  Create user with UID of 502
2.  Install satellite 410

  
Actual results:
nocpulse user isn't created.  Monitoring doesn't work.

Expected results:
nocpulse user should be created.  Monitoring should work.

Comment 3 Robin Norwood 2006-10-17 16:48:58 UTC
mass reassign to mmccune

Comment 4 Jan Pazdziora 2007-10-30 20:04:30 UTC
Aligning against rhn42maint, taking from Mike's queue.

Comment 5 Brandon Perkins 2007-10-31 14:38:52 UTC
Remove linkage to bug 306501 to keep things clean for 510.

Comment 6 Clifford Perry 2008-04-03 17:06:01 UTC
Fixed in Sat 5.1. WONTFIX for 4.2. 


Note You need to log in before you can comment on or make changes to this bug.