Bug 204812 - gftp segfault when deleting large directory
gftp segfault when deleting large directory
Status: CLOSED DUPLICATE of bug 204811
Product: Fedora
Classification: Fedora
Component: gftp (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-08-31 13:55 EDT by FX
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-31 14:31:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description FX 2006-08-31 13:55:00 EDT
Connected to an FTP server (ftpperso.free.fr) with non-anonymous login, I
selected a directory in the root directory, right-clicked on it and selected
"Delete". After quite some time listing files to delete (with a nice bouncing
progress bar), gftp segfaults.

The gdb backtrace of the segfault (with binary gftp-gtk) is:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1226515552 (LWP 19768)]
0x00970402 in __kernel_vsyscall ()
(gdb) where
#0  0x00970402 in __kernel_vsyscall ()
#1  0x082fd780 in ?? ()
#2  0x0000000f in ?? ()
#3  0x00000000 in ?? ()

The problem occurs with gftp-2.0.18-3.2.1. I don't know if it's reproducible on
other servers or other directories.
Comment 1 FX 2006-08-31 14:31:09 EDT

*** This bug has been marked as a duplicate of 204811 ***

Note You need to log in before you can comment on or make changes to this bug.