Bug 204819 - Fail to handle Asynchronous Event Notification for lun change
Fail to handle Asynchronous Event Notification for lun change
Status: CLOSED DUPLICATE of bug 204818
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike Christie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 14:25 EDT by liu_haihua
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 12:25:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description liu_haihua 2006-08-31 14:25:20 EDT
Description of problem:
After receiving the Asynchronous Event Notification for lun change from the 
iscsi target, the iscsi driver just logs the event to /var/log/messages and 
ignores the event. The iscsi driver supposes take action to discover the lun 
change. See iscsi-recv-pdu.c 386: iscsi_host_info(session, "Received async SCSI 
event. Print", "sense");

Version-Release number of selected component (if applicable): 
name: iscsi-initiator-utils
version: 4.0.3.0
Release: 3


How reproducible:


Steps to Reproduce:
1. connect the iscsi initiator to the iscsi target
2. generate the Asynchronous Event Notification by granting/disable the LUN on 
the iscsi target.
3.
  
Actual results:
Can't discover the lun change from iscsi target side. Only log the 
message, "Received async SCSI event. Print sense", to the /var/log/messages.

Expected results:
Discover the lun change.

Additional info:
Comment 1 Mike Christie 2006-09-06 12:25:26 EDT

*** This bug has been marked as a duplicate of 204818 ***

Note You need to log in before you can comment on or make changes to this bug.