Bug 204943 - gnome_segv should not spawn bug-buddy when bug-buddy crashes
gnome_segv should not spawn bug-buddy when bug-buddy crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomeui (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-01 11:27 EDT by Matthew Barnes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: libgnomeui-2.15.91-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 15:30:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 353760 None None None Never

  None (edit)
Description Matthew Barnes 2006-09-01 11:27:09 EDT
Description of problem:
The gnome_segv program should check that the aborted application was not
bug-buddy before spawning bug-buddy.  If bug-buddy aborts on start-up, GNOME
starts to repeatedly spawn new bug-buddy instances until you run out of memory.

Version-Release number of selected component (if applicable):
libgnomeui-2.15.91-1.fc6

How reproducible:
If you can coax bug-buddy into aborting on startup, always.

Steps to Reproduce:
1. $ export G_DEBUG=fatal_warnings
2. $ bug-buddy --package=gnome-terminal  (any package name will do)
  
Actual results:
At least with the version I'm running (2.15.92), bug-buddy will produce some
spurious warning about not being able to load an icon.

The warning will cause bug-buddy to abort (due to the G_DEBUG setting), which
will spawn bug-buddy, which will produce the same warning, which will cause
bug-buddy to abort, which will spawn bug-buddy... and so on.

Expected results:
The gnome_segv program should give up if bug-buddy itself crashes.

Additional info:
Already filed this upstream, along with a patch:
http://bugzilla.gnome.org/show_bug.cgi?id=353760
Comment 1 Matthias Clasen 2006-09-01 14:26:26 EDT
nice. Wil you put that patch in rawhide, Matt ?
Comment 2 Matthew Barnes 2006-09-01 15:30:31 EDT
Done.  Fixed in libgnomeui-2.15.91-2.fc6.

Note You need to log in before you can comment on or make changes to this bug.