Bug 204944 - gnome-screensaver package causes rss-glx hacks to appear twice in screensaver preferences
gnome-screensaver package causes rss-glx hacks to appear twice in screensaver...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-01 11:29 EDT by Nils Philippsen
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 05:53:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2006-09-01 11:29:32 EDT
Description of problem:

Because gnome-screensaver RPM triggers and scripts run
migrate-xscreensaver-config.sh across the board on all xml files found in
/usr/share/xscreensaver/config, it causes rss-glx hacks to appear twice in the
gnome-screensaver preferences dialog (if either of xscreensaver{,-gl}-extras is
installed).

Version-Release number of selected component (if applicable):

gnome-screensaver-2.15.7-1.fc6
gnome-screensaver-2.14.3-1.fc5

How reproducible:

Easy.

Steps to Reproduce:
1. Install gnome-screensaver, rss-glx-gnome-screensaver, rss-glx-xscreensaver
and either of xscreensaver-extras or xscreensaver-gl-extras
2. Start the gnome-screensaver preferences dialog

Actual results:

Duplicate entries for all rss-glx hacks, e.g. BioF

Expected results:

Only one entry for each hack, no automatic conversion from xscreensaver config
files of rss-glx hacks to gnome-screensaver desktop files.

Additional info:

Same on FC5.

No points for using RPM triggers at all, on account of them being an abomination
;-). This issue could be easily solved with build-time generated
gnome-screensaver config files for the xscreensaver hacks. If desired, these
could be put into respective subpackages, e.g.
"xscreensaver-extras-gnome-screensaver" or even "...-gss-compat" if the former
is too long.
Comment 1 Mamoru TASAKA 2006-09-02 03:33:30 EDT
Hello, Nils:

Well, I don't use gnome-screensaver (so currently I don't install
gnome-screensaver) and I don't know well about
gnome-screensave mechanism, however, I can understand what you
mean.

When migrate-xscreensaver-config.sh is invoked, it creates
xscreensaver-biof.desktop, however, rss-glx-gnome-screensaver has
rss-glx-biof.desktop, I am right? Well the problem is

* Maybe duplicate entries on gnome-screensaver appears.
* xscreensaver-???.desktop is not owned.

So, having xscreensaver own proper desktop files may be the best
idea to solve this an Nils pointed out. Will you check the rpms
under 

http://www.ioa.s.u-tokyo.ac.jp/~mtasaka/dist/extras/development/RPMS/i386/ ?
( I only have i386 arch )
Comment 2 Nils Philippsen 2006-09-05 11:24:42 EDT
Hi Mamoru (<-is that your first name?),

your RPMs look good, but you should do:

Requires: gnome-screensaver

in the xscreensaver-extras-gss and xscreensaver-gl-extras-gss subpackages.
Please do that for FC5 and devel, then ping me once you've done that and the
packages got pushed, so that I can build the adjusted gnome-screensaver packages
which _will_ conflict with the older xscreensaver packages. Thanks.
Comment 3 Nils Philippsen 2006-09-05 11:34:29 EDT
Mamoru, forgot one thing: be aware that the directory for the desktop files is
different in FC5 (/usr/share/gnome-screensaver/themes) and devel
(/usr/share/applications/screensavers).
Comment 4 Nils Philippsen 2006-09-05 11:35:18 EDT
Forget it, xscreensaver is in Core for FC5, I'll do the update then.
Comment 5 Mamoru TASAKA 2006-09-05 11:41:50 EDT
(In reply to comment #2)
(Note: I have not committed -19 yet)

> Hi Mamoru (<-is that your first name?),
> 
> your RPMs look good, but you should do:
> 
> Requires: gnome-screensaver
> 
> in the xscreensaver-extras-gss and xscreensaver-gl-extras-gss subpackages.

Okay.

> Please do that for FC5 and devel,

I am afraid I can't. I can (and will do) fix devel xscreensaver (in FE),
of which the owner is me. However, I cannot fix FC5 xscreensaver 
of which the owner is Ray, not me and I cannot fix core packages.......
Comment 6 Mamoru TASAKA 2006-09-05 12:26:29 EDT
For FE6-devel xscreensaver, building is done.
http://buildsys.fedoraproject.org/build-status/job.psp?uid=16247

(In reply to comment #4)
> Forget it, xscreensaver is in Core for FC5, I'll do the update then.
Understand.
Nils, among bugs opened against FC5 core xscreensaver, bug 182552
(conflict issue) is perhaps the most annyoing issue.

If you fix FC5 xscreensaver, will you add

for f in hacks/Makefile.in hacks/glx/Makefile.in ; do sed -i.mansuffix -e
'/^mansuffix/s|^.*$|mansuffix = 6|' $f ; done

in %prep stage to fix bug 182552 ?

Comment 7 Nils Philippsen 2006-09-05 17:13:16 EDT
fixed for Rawhide in gnome-screensaver-2.16.0-2.fc6, for FC-5 in
gnome-screensaver-2.14.3-1.fc5, xscreensaver-4.24-3.fc5 (the latter is still
building).
Comment 8 Fedora Update System 2006-09-07 08:53:06 EDT
gnome-screensaver-2.14.3-3.fc5 xscreensaver-4.24-3.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 9 Fedora Update System 2006-09-08 10:32:55 EDT
gnome-screensaver-2.14.3-3.fc5 xscreensaver-4.24-3.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 10 Andrew Zabolotny 2006-12-09 13:11:29 EST
There's something wrong with the Fedora 6 packages: they don't contain the
.desktop files, and the gnome-screensaver rpm doesn't contain the
migrate-xscreensaver-config.sh script; as a result you can't use any of the
xscreensaver plugins with gnome-screensaver:

[2|root@zap|~]rpm -ql gnome-screensaver-2.16.1-2.fc6 | grep desktop
/usr/share/applications/gnome-screensaver-preferences.desktop
/usr/share/applications/screensavers/cosmos-slideshow.desktop
/usr/share/applications/screensavers/footlogo-floaters.desktop
/usr/share/applications/screensavers/personal-slideshow.desktop
/usr/share/applications/screensavers/popsquares.desktop
/usr/share/desktop-directories/gnome-screensaver.directory
[2|root@zap|~]rpm -ql xscreensaver-extras-5.01-5.fc6 | grep desktop
[2|root@zap|~]rpm -ql xscreensaver-gl-extras-5.01-5.fc6 | grep desktop
[2|root@zap|~]rpm -ql gnome-screensaver-2.16.1-2.fc6 | grep migrate
[2|root@zap|~]
Comment 11 Mamoru TASAKA 2006-12-09 13:27:21 EST
(In reply to comment #10)
> There's something wrong with the Fedora 6 packages: they don't contain the
> .desktop files, and the gnome-screensaver rpm doesn't contain the
> migrate-xscreensaver-config.sh script; as a result you can't use any of the
> xscreensaver plugins with gnome-screensaver:

Please install xscreensaver-extras-gss or xscreensaver-gl-extras-gss.

Note You need to log in before you can comment on or make changes to this bug.