Bug 20498 - texi2dvi does not recognize indices with extension ?o
texi2dvi does not recognize indices with extension ?o
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: texinfo (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 17:58 EST by vigna
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 17:58:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description vigna 2000-11-07 17:58:02 EST
When texi2dvi compiles a texinfo file, it recognize the index files by
filtering the xref files with the following sed program

    index_files=`echo "$orig_xref_files" \
                 | sed "s!.*\.aux!!g;
                        s!./$filename_noext\..o.!!g;
                        s/^[ ]*//;s/[ ]*$//"`


This however is wrong if there is a defined index with extension .co,
because it will be cut by the third line filter. The "\..o." part
should be really "\..o[^ ]", so that you do not match ".co" followed by a
space.
Comment 1 Bernhard Rosenkraenzer 2000-11-08 10:37:53 EST
Fixed in -17

Note You need to log in before you can comment on or make changes to this bug.