Bug 20498 - texi2dvi does not recognize indices with extension ?o
Summary: texi2dvi does not recognize indices with extension ?o
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: texinfo   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-07 22:58 UTC by vigna
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 22:58:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description vigna 2000-11-07 22:58:02 UTC
When texi2dvi compiles a texinfo file, it recognize the index files by
filtering the xref files with the following sed program

    index_files=`echo "$orig_xref_files" \
                 | sed "s!.*\.aux!!g;
                        s!./$filename_noext\..o.!!g;
                        s/^[ ]*//;s/[ ]*$//"`


This however is wrong if there is a defined index with extension .co,
because it will be cut by the third line filter. The "\..o." part
should be really "\..o[^ ]", so that you do not match ".co" followed by a
space.

Comment 1 Bernhard Rosenkraenzer 2000-11-08 15:37:53 UTC
Fixed in -17


Note You need to log in before you can comment on or make changes to this bug.