Bug 204991 - man - makewhatis unable to handle various manpages
man - makewhatis unable to handle various manpages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-01 17:25 EDT by Michal Jaegermann
Modified: 2013-07-02 19:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 08:21:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-09-01 17:25:00 EDT
Description of problem:

A peek into /var/cache/man/whatis reveals "lines" of that sort:

and bottom means flush bottom. .sp The -yoff option modifies ....

(followed by big pieces of a "raw" manpage data).

It seems that in particular pages from 'netpbm' package are good
in tripping /usr/sbin/makewhatis but quite possibly something else
too. 'rpm -qf /usr/share/man/man1/netpbm.1.gz' responds here with
'netpbm-progs-10.34-4.fc6'. Makes for an "interesting" output
from 'man -k color'. :-)

/usr/sbin/makewhatis seems to attempt to parse every possible
variation in manpage sources hence results are not that surprising.

Version-Release number of selected component (if applicable):
man-1.6d-1.1
Comment 1 Ivana Varekova 2006-09-06 06:09:06 EDT
This is netpdb man-pages problem. It's man pages have wrong syntax - there
should be 
.SH <section_name>
instead of 
.UN <text> .SH <section_name>
for all section names.
Comment 2 Michal Jaegermann 2006-09-06 12:32:38 EDT
> This is netpdb man-pages problem. It's man pages have wrong syntax

Out of curiosity - does there exist a document which describes
syntax requirements for a man page?  Beyond obvious that it should
be acceptable for nroff/troff with 'man' macros, that is.

When I am looking at an FC5 installation then the same problem shows
up and /var/cache/man/whatis pretty close to the top has big, but
wrong, pieces from a manpage of rletopnm.  There is more of similar
stuff further down although at least some pages from netpbm kit
were obviously handled without problems.

Try

   grep '\... ' /var/cache/man/whatis

with an FC5 too, and this should catch enough examples.  Doing such
experiment on a CentOS installation (hence most likely on RHEL too
but I do not have such handy) immediately brought garbled in
/var/cache/man/whatis manpage for GLwCreateMDrawingArea (and many more).
That one is supplied by 'xorg-x11-devel' package.  A damage in those
cases is much less extensive for some reasons and 'man -k ...' is
not seriously affected.
Comment 3 Jindrich Novy 2006-09-07 07:41:54 EDT
All the netpbm man pages are generated by "makeman" script directly from the
http documentation on the web. It seems like it's needed to either fix the
makeman script or the web pages the man pages are generated from.

From the makeman script (which is a part of the netpbm srpm) I read:
$ grep makeman "\.UN"

    # Turn anchors into .UN tags
    indoc = re.sub('(?i)<A NAME *=
*"#?([a-zA-Z][a-zA-Z0-9.-]+)">(?:&nbsp;)*</A>\s*', ".UN \\1\n", indoc)
                   ".UN \\1\n.SH \\2", indoc)
                   ".UN \\1\n.SS \\2", indoc)
                   ".UN \\1\n.B \\2", indoc)
                   ".UN \\1.SH \\2", indoc)
                   ".UN \\1\n.SS \\2", indoc)
                   ".UN \\1\n.B \\2", indoc)

it seems like there's missing '\n' in one substitution there.
Comment 4 Jindrich Novy 2006-09-07 08:21:20 EDT
Fixed since netpbm-10.34-6.fc6.

Note You need to log in before you can comment on or make changes to this bug.