Bug 205033 - IDN support in jwhois
IDN support in jwhois
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-02 15:44 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.2.3-8
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 12:02:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-09-02 15:44:35 EDT
Description of problem:
Is it possible to upgrade jwhois to latest CVS, to get the IDN support in
jwhois into Fedora Core 6?

Version-Release number of selected component (if applicable):
jwhois-3.2.3-6.1

Actual results:
No IDN support in jwhois

Expected results:
IDN support in jwhois, upgrading to jwhois cvs will require libidn-devel as 
build requirement.
Comment 1 Miloslav Trmač 2006-09-08 18:14:18 EDT
Sure, after FC6.
Comment 2 Robert Scheck 2006-09-08 18:26:51 EDT
Why after FC6?
Comment 3 Miloslav Trmač 2006-09-08 18:37:34 EDT
FC6t3 is already frozen, and the feature freeze is long past, as you can see at
http://fedoraproject.org/wiki/Core/Schedule
Comment 4 Robert Scheck 2006-09-09 19:41:56 EDT
But pushing it as update for FC5 and FC6 should be possible then, shouldn't it?
Comment 5 Robert Scheck 2006-10-29 18:54:48 EST
Ping?
Comment 6 Fedora Update System 2006-10-31 14:57:15 EST
jwhois-3.2.3-8.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Fedora Update System 2006-10-31 14:57:54 EST
jwhois-3.2.3-8.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Robert Scheck 2006-11-01 06:25:25 EST
Miloslav, I dunno what you've got checked out, but your output character 
conversion from bug #132362 is missing which is a urgent part of IDN support. 
Finally your config file is never ever from Oct 31 2006, because of e.g. the 
following missing things:

@@ -921,17 +925,10 @@
        "whois\\.denic\\.de" {
                whois-server = "whois.denic.de";
                query-format = "-C UTF-8 -T dn,ace $*";
-               answer-charset = "UTF-8";
        }
        "whois\\.nic\\.ad\\.jp" {
                query-format = "$*/e";
        }
-       "whois\\.nic\\.ch" {
-               answer-charset = "UTF-8";
-       }
-       "whois\\.nic\\.li" {
-               answer-charset = "UTF-8";
-       }
 }

 #
Comment 9 Robert Scheck 2006-11-01 06:30:36 EST
To make it shorter: Most of the following changelog entry is missing, which 
unfortunately includes the better IPv6 support written by yourself, too.

2006-05-20  Jonas Oberg  <jonas@gnu.org>

        * Added patch to support conversion of whois server output to
        local charset. Fixes Fedora Core bug #132362 (Miloslav Trmac)

        * configure.in: Added check for IPv6-aware inet_pton

        * src/jwhois.c (main): Added support for libidn. (Robert Scheck)

        * src/lookup.c (lookup_host): Added lookup to cidr6 blocks.
        (Miloslav Trmac)

        * example/jwhois.conf: Added cidr6-blocks structure and moved all
        IPv6 addresses to it. (Miloslav Trmac)

        * doc/jwhois.texi: Added documentation for cidr6 support. (Miloslav
        Trmac)
Comment 10 Miloslav Trmač 2006-11-01 14:34:16 EST
jwhois-3.2.3-idn.patch backports only the IDN support;  I still don't want to
include new config options until they are oficially released upstream.

That's why the answer-charset option and the new IPv6 matching code are not
present and were manually removed from the config file updates.

I think the IDN support is still useful (considering the answer-charset values
in the config file are all equal to the system default);  if you feel otherwise,
the best I can do right now is to drop the updates completely.
Comment 11 Fedora Update System 2006-11-09 11:59:52 EST
jwhois-3.2.3-8.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 12 Fedora Update System 2006-11-09 12:01:25 EST
jwhois-3.2.3-8.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 13 Robert Scheck 2006-11-09 12:05:30 EST
Mhm, whatever meens FIXED. Personally I only can agree with you in parts but 
I'll not reopen, because there's no chance to get what I would like to see.

Note You need to log in before you can comment on or make changes to this bug.