Bug 205047 - Spec file alterations
Summary: Spec file alterations
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Nielsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-02 23:42 UTC by Paul F. Johnson
Modified: 2008-02-02 06:30 UTC (History)
0 users

Fixed In Version: beagle-0.3.2-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-02 06:30:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Beagle patch file (2.62 KB, patch)
2006-09-02 23:42 UTC, Paul F. Johnson
no flags Details | Diff

Description Paul F. Johnson 2006-09-02 23:42:51 UTC
Description of problem:

The attached patch fixes the spec file for beagle so that it conforms with the
packaging guidelines

It adds the devel package for the pkgconfig and makes subpackages reliant on the
version and release of the main package. It also globs some of the files
included in the %files directory (makes it a tad more readable IMO)

Comment 1 Paul F. Johnson 2006-09-02 23:42:51 UTC
Created attachment 135437 [details]
Beagle patch file

Comment 2 Matthias Clasen 2006-09-03 01:04:50 UTC
Adding a -devel package containing just a .pc file is just ridiculous.

Comment 3 Paul F. Johnson 2006-09-03 08:45:31 UTC
Thems are the guidelines - I've been hauled up for it on the extras packages
before now.

Comment 4 Toshio Kuratomi 2006-09-04 15:19:27 UTC
(In reply to comment #2)
> Adding a -devel package containing just a .pc file is just ridiculous.

Perhaps.

It's in the packaging guidelines, though.  The reasoning is found here:
https://www.redhat.com/archives/fedora-extras-list/2006-May/msg00340.html

The start of the thread is here:
https://www.redhat.com/archives/fedora-extras-list/2006-May/msg00296.html

If you have an alternative or would like to explain why the reasoning is bogus
the packaging committee would be happy to hear it (the rule stinks but the
dependency chain pulling in -devel packages stinks worse.)

The rule may be overbroad as well.  If you have examples of packages where the
reasoning doesn't apply we can modify the guidelines to account for those.  If
you come up with language that expresses the restrictions and the exceptions
accurately, that's even better.  The Packaging Committee has email discussions
on: fedora-packaging[AT]redhat.com and IRC meetings on #fedora-packaging.

Comment 5 Alexander Larsson 2006-09-06 09:40:51 UTC
I applied some of the changes in 0.2.9-2.
I don't like the globbing. That can to easily break in later versions when new
files get added.
Also, i didn't break out the -devel package, because that will cause multilib
conflicts. If we need to do this we need to fix the conflicts in the bin wrappers.


Comment 6 David Nielsen 2008-02-02 06:30:06 UTC
This seems an over and done with issue, if not then please reopen.


Note You need to log in before you can comment on or make changes to this bug.