Bug 205077 - gnome-volume-control enhancement request
gnome-volume-control enhancement request
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-03 17:05 EDT by Steve
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 07:47:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (1.59 KB, text/plain)
2006-09-03 17:05 EDT, Steve
no flags Details
dmesg (17.71 KB, text/plain)
2006-09-03 17:09 EDT, Steve
no flags Details

  None (edit)
Description Steve 2006-09-03 17:05:41 EDT
Description of problem:
This is a enhancement request and less bug related and applies to audio
configuration.

gnome-volume-control:
get rid of ability to change volume with PCM and headphone.
ex: I can change volume level with master volume and pcm if i dont use
headphones, however if i do, then headphones and pcm change volume level. To
lower volume, i must lower say both master and pcm.

Expected results:
basically get rid of headphone and pcm.
only master volume should be used and it should be able to control headphone
level as well. This would help largly since i have multimedia audio keys binded
to master volume.


Additional info:
i can attach relevent output like lspci and dmesg
Comment 1 Steve 2006-09-03 17:05:41 EDT
Created attachment 135466 [details]
lspci output
Comment 2 Steve 2006-09-03 17:09:28 EDT
Created attachment 135467 [details]
dmesg

this is dmesg output for my computer.

base computer info:
Dell Inspiron 9300, Centrino 1.86GHZ, 1GB DDR2 533 2x512 dual channel, 80GB IDE
drive on SATA controller, SONY atapi dvd writer on SATA controller, Sigmatel
integrated audio, ATI x300 128MB mobility.
Comment 3 Steve 2006-10-25 01:24:28 EDT
im thinking this should have gone to alsa-lib / alsa-utils ?? not sure
but i did a fresh install of FC6 and will retest
Comment 4 Bastien Nocera 2007-10-02 07:38:16 EDT
Yep, this is a problem with alsa-lib and the kernel bits showing us far too much
of the physical mixer tracks for user-space applications to handle nicely.

Let us know whether the problem is fixed with FC6 (or better, F7 or rawhide)
Comment 5 Martin Stransky 2007-10-02 07:47:51 EDT
This is caused by broken ALSA design. I'm not going to rewrite it completely.
Closing as WONTFIX. You can report it directly at ALSA project
(www.alsa-project.org).

Note You need to log in before you can comment on or make changes to this bug.