Bug 205117 - Installation fails on s390 when trying to log in through telnet
Installation fails on s390 when trying to log in through telnet
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-04 07:15 EDT by Matthias Saou
Modified: 2013-01-09 23:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 14:02:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-09-04 07:15:47 EDT
I just tried to install today's Rawhide (20060904) for s390 with hercules.
Everything went fine until the installation process started telnet/sshd in order
to continue the process. Here is the hercules output :

[...]
Starting telnetd and sshd to allow login over the network.
INFO: trying to register non-static key.
the code is fine but needs lockdep annotation.
turning off the locking correctness validator.
002db688 015d399c 8002f736 8002f774 015d3950 015d3998 00000002 00000000
       015d39f8 015d39b4 015d39b4 80016190
Call Trace:
( <0000000000016098>! show_trace+0x80/0xfc)
  <00000000000161a8>! show_stack+0x94/0xb4
  <00000000000161f0>! dump_stack+0x28/0x38
  <0000000000050f22>! __lock_acquire+0x97a/0xad0
  <000000000005178c>! lock_acquire+0x64/0x8c
  <000000000022af30>! _spin_lock_irqsave+0x50/0x70
  <0000000010892588>! ctc_tx+0x220/0xa28  ctc!
  <00000000001b1d92>! dev_hard_start_xmit+0x18e/0x23c
  <00000000001c40c4>! __qdisc_run+0xe8/0x20c
  <00000000001b4372>! dev_queue_xmit+0x132/0x28c
  <00000000001daca0>! ip_output+0x23c/0x2cc
  <00000000001da618>! ip_build_and_send_pkt+0x230/0x27c
  <00000000001ef58e>! tcp_v4_send_synack+0xc6/0x160
  <00000000001f1fe4>! tcp_v4_conn_request+0x45c/0x554
  <00000000001e8732>! tcp_rcv_state_process+0x6e/0xe94
  <00000000001f0662>! tcp_v4_do_rcv+0x2ee/0x3c8
  <00000000001f3448>! tcp_v4_rcv+0xaec/0xc30
  <00000000001d4a54>! ip_local_deliver+0x1f4/0x33c
  <00000000001d478e>! ip_rcv+0x556/0x628
  <00000000001b17c4>! netif_receive_skb+0x2bc/0x37c
  <00000000001b3574>! process_backlog+0xb4/0x1a0
  <00000000001b3c2a>! net_rx_action+0xb2/0x1d4
  <0000000000035b80>! __do_softirq+0x78/0x134
  <000000000001e860>! do_softirq+0x7c/0xbc
  <0000000000035f76>! irq_exit+0x6a/0x84
  <00000000001666fe>! do_IRQ+0x13e/0x170
  <000000000001f094>! io_no_vtime+0x14/0x1a
  <000000000043e452>! stack_trace+0x33dba/0x80000


Connect now to 192.168.200.3 to start the installation.

And telnet doesn't work :

$ telnet 192.168.200.3
Trying 192.168.200.3...
Connected to 192.168.200.3 (192.168.200.3).
Escape character is '^]'.
getaddrinfo: localhost: No such file or directory
No address associated with hostname: Illegal seek
Connection closed by foreign host.

And ssh asks to save the key, but then "Connection closed by 192.168.200.3".

Could this be an s390 specific network problem? Or something done wrong in the
s390 installation process? To reproduce, simple follow the instructions found in
the README.fedora file of the hercules package found in Extras.
Comment 1 Jeremy Katz 2006-09-06 01:54:24 EDT
It's something bizarre with telnet... I think it might be worth nuking telnet
given how common ssh is at this point

Any disagreement?
Comment 2 Matthias Saou 2006-09-06 05:04:01 EDT
It used to still work a couple of months ago at most...
And didn't someone (yourself?) mention on a fedora list in the past few days
that the reason why openssh-server generated its keys upon first startup instead
of when the package gets installed was because it made a huge difference for the
install time on some s390 machines?
I'm just asking because I'm not sure I see the real advantage of ssh over telnet
in this case... unless the keys at that point are going to be kept for the
installed system? That would be a nice feature.
Comment 3 Karsten Hopp 2006-09-06 05:11:58 EDT
re comment #2: it made a huge difference on our 31bit MP3000, but key generation
is almost instantaneous on our zSeries machine. It's been a while since my last
Hercules installation, how long does key generation take at the first boot after
the installation ?
btw: was this really an s390 installation or s390x ?

re comment #1:
telnetd aborts with a segfault (on s390x):
[pid   495] mprotect(0x20000214000, 4096, PROT_READ) = 0
[pid   495] open("/etc/passwd", O_RDONLY) = 4
[pid   495] fcntl(4, F_GETFD)           = 0
[pid   495] fcntl(4, F_SETFD, FD_CLOEXEC) = 0
[pid   495] fstat(4, {st_mode=S_IFREG|0644, st_size=128, ...}) = 0
[pid   495] mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0x200001fd000
[pid   495] read(4, "root::0:0::/:/sbin/loader\ndebug::0:0:debug
shell:/:/bin/bash\nsshd:x:74:74:Privilege-separated
SSH:/var/empty/sshd:/sbin/nologin\n", 4096) = 128
[pid   495] --- SIGSEGV (Segmentation fault) @ 0 (0) ---
Process 495 detached
<... select resumed> )                  = 1 (in [3])
--- SIGCHLD (Child exited) @ 0 (0) ---
read(3, 0x80200fe8, 4000)               = -1 EIO (Input/output error)


I'm not sure if we should kick telnet, but have no strong objections either.
Comment 4 Matthias Saou 2006-09-06 05:23:34 EDT
I'm not against nuking telnet... just trying to make sure it won't become an
issue for RHEL5 users. I used hercules with the default configuration I've
included in the Fedora Extras package : CPUMODEL 3090 and ARCHMODE ESA/390 then
used the files from s390/os/images/ (and not s390x of that was the question).

For anyone wanting to reproduce this without any actual s390 hardware, I've made
sure that the hercules package comes in a "ready to run" shape. Simply install
it and follow the instructions from /usr/share/doc/hercules-*/README.fedora (for
FC devel, RHEL4 and RHL 7.2). You get your own mainframe in no time! I'm running
it on a 64bit Xeon 3GHz and it's not fast, but not too slow either.
Comment 5 David Cantrell 2006-09-06 10:19:49 EDT
Thanks for the hercules info, Matthias.  I'm still waiting on the zSeries
Luggable from IBM.  :)

On nuking telnet... I'm all in favor of it.  With the addition of IPv6 in to
anaconda, binding telnet and/or expanding it to make it work with IPv6 is just
unnecessarily annoying.  I don't think the key generation time required by sshd
will be that bad and users can deal with it.

My two cents.
Comment 6 David Cantrell 2007-10-24 14:02:10 EDT
I've removed telnet login support for s390 installation from rawhide.  Going
forward, ssh will be the only supported method for connecting to the s390
installer instance.

For the RHEL-5 bug, we fixed the telnet connection problem in 5.1.

I am closing this as WONTFIX since I'm not doing any more telnet support for
s390 installs in Fedora.

Note You need to log in before you can comment on or make changes to this bug.