Bug 205120 - devhelp-0.10-0.2.el4 uses old mozilla-suite shared libs
Summary: devhelp-0.10-0.2.el4 uses old mozilla-suite shared libs
Status: CLOSED DUPLICATE of bug 202034
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: devhelp   
(Show other bugs)
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-04 11:33 UTC by Bryn M. Reeves
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 19:25:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryn M. Reeves 2006-09-04 11:33:23 UTC
Description of problem:
devhelp RPM shipped in RHEL4U4 explicitly depends on mozilla = 37:1.8 but
requires shared libraries from mozilla = 37:1.7.xx

Version-Release number of selected component (if applicable):

devhelp-0.10-0.2.el4
seamonkey-1.0.3-0.el4.1

Steps to Reproduce:
1. Install devhelp on an updated U4 machine.
2. Attempt to run devhelp
 
Actual results:
# devhelp
devhelp: error while loading shared libraries: libgtkembedmoz.so: cannot open
shared object file: No such file or directory

# LD_LIBRARY_PATH=/usr/lib/mozilla-seamonkey-1.0.3/ devhelp
devhelp: symbol lookup error: /usr/lib/libdevhelp-1.so.0: undefined symbol:
_ZTV24nsGetServiceByContractID
Expected results:

devhelp should start without use of LD_LIBRARY_PATH and without undefined symbol
errors.

Additional info:
devhelp-0.10-0.2.el4 clearly contains a reference to the old mozilla-suite
shared lib:

# ldd /usr/lib/libdevhelp-1.so.0 | grep gtkembed
        libgtkembedmoz.so => not found

# readelf -a /usr/bin/devhelp | grep moz
 0x00000001 (NEEDED)                     Shared library: [libgtkembedmoz.so]
 0x0000000f (RPATH)                      Library rpath: [/usr/lib/mozilla-1.7.13]

Manually installing mozilla from U3 (1.7.12) and forcing LD_LIBRARY_PATH allows
devhelp-0.10-0.2.el4 to run fine.

Also, using up2date to install devhelp when seamonkey is NOT installed results
in an unresolvable chain of dependancies:

# up2date devhelp

Fetching Obsoletes list for channel: rhel-i386-es-4...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
devhelp                                 0.10           0.2.el4           i386


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
devhelp  0.10-0.2.el4                    requires libgtkembedmoz.so
devhelp  0.10-0.2.el4                    requires libnspr4.so
devhelp  0.10-0.2.el4                    requires libplc4.so
devhelp  0.10-0.2.el4                    requires libplds4.so
devhelp  0.10-0.2.el4                    requires libxpcom.so
devhelp-0.10-0.2.el4                     requires mozilla = 37:1.8


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------

I can file that last one as a separate bug if preferred, but it seems related.

Comment 1 Bryn M. Reeves 2006-09-04 19:25:41 UTC

*** This bug has been marked as a duplicate of 202034 ***


Note You need to log in before you can comment on or make changes to this bug.