Bug 205126 - segfault when I exit mutt
segfault when I exit mutt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-04 08:31 EDT by Dave Jones
Modified: 2015-01-04 17:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-21 13:17:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-09-04 08:31:30 EDT
mutt dumped core when I quit it today.  I can't reproduce it, but here's the
backtrace..

Core was generated by `mutt'.
Program terminated with signal 11, Segmentation fault.
#0  0x00000033c4861319 in fclose@@GLIBC_2.2.5 () from /lib64/libc.so.6
(gdb) bt
#0  0x00000033c4861319 in fclose@@GLIBC_2.2.5 () from /lib64/libc.so.6
#1  0x00000000004585c3 in safe_fclose (f=0x8d84f8) at lib.c:127
#2  0x0000000000435554 in mx_fastclose_mailbox (ctx=0x8d84f0) at mx.c:760
#3  0x000000000042f620 in mbox_sync_mailbox (ctx=0x8d84f0, 
    index_hint=<value optimized out>) at mbox.c:960
#4  0x0000000000436991 in mx_close_mailbox (ctx=0x8d84f0, 
    index_hint=0x7fffe77da0bc) at mx.c:999
#5  0x000000000041afce in mutt_index_menu () at curs_main.c:822
#6  0x000000000042d672 in main (argc=1, argv=0x7fffe77db138) at main.c:842
#7  0x00000033c4820ab4 in __libc_start_main () from /lib64/libc.so.6
#8  0x00000000004058b9 in _start ()
Comment 1 Miroslav Lichvar 2007-02-21 13:17:00 EST
mutt-1.5.13 is in devel now.

I'm closing the bug as it's likely that this bug was fixed since version 1.4.
Please reopen if it's not the case.

Note You need to log in before you can comment on or make changes to this bug.