Bug 205130 - P4 Mobile wrong CPU scaling with 2.6.17 FC4 and FC5 kernels.
P4 Mobile wrong CPU scaling with 2.6.17 FC4 and FC5 kernels.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-04 09:28 EDT by paolo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 01:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description paolo 2006-09-04 09:28:52 EDT
+++ This bug was initially created as a clone of Bug #204477 +++

Description of problem:

With both Fedora 4 and Fedora 5 and a HP Omnibook xe4500 (P4 mobile 1.7), since
I upgraded the kernel to 2.6.17 the CPU scaling is wrong.

With all the other kernels up to 2.6.16 everything was fine, I used p4_clockmod
with cpuspeed to manage the scaling when the processor was too hot or the laptop
running on batteries.

It seems that in kernel 2.6.17 speedstep-smi driver is compiled in the kernel
and it's loaded by default, preventing me from loading p4-clockmod.

QUOTE:
#cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
speedstep-smi
#/sbin/modprobe p4_clockmod
FATAL: Error inserting p4_clockmod
(/lib/modules/2.6.17-1.2143_FC4/kernel/arch/i386/kernel/cpu/cpufreq/p4-clockmod.ko):
Device or resource busy

speedstep-smi doesn't work well with my processor, it incorrectly sets
cpuinfo_max_freq to 666000 instead of 1700000 and scaling_available_frequencies
to "642000 666000".

p4-clockmod correctly used to set cpuinfo_max_freq to 1700000 and
scaling_available_frequencies to "212500 425000 637500 850000 1062500 1275000
1487500 1700000".

Version-Release number of selected component (if applicable):
The above problem applies to all available 2.6.17 kernels of FC4 and FC5
distributions.

Here is my cpuinfo file:
cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 Mobile CPU 1.70GHz
stepping        : 4
cpu MHz         : 1700.000
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3403.91

How reproducible:
I'm not sure about that since I don't have a different P4 Mobile machine to test
and googling around for the problem gave me no results it may as well be an
issue with this specific laptop or processor.

Steps to Reproduce:

1. Just update the kernel to any 2.6.17 releases
2.
3.
  
Actual results:
I solved compiling my own kernel from the sources and setting speedstep-smi as
external module.

Expected results:
I would like to see speedstep-smi compiled as loadable module as in previous
kernel versions.

Additional info:
Comment 1 David Lawrence 2006-09-05 11:57:11 EDT
Changing to proper owner, kernel-maint.
Comment 2 Dave Jones 2006-09-16 23:20:38 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 3 paolo 2006-09-17 01:30:12 EDT
Since this bug applies also to FC5 already posted it there as Bug #204477 but
I've seen no activity there.

Browsing the internet I've not found other FC users with the same problem,
however users of other distributions experienced similar problems. 

I think a user (especialy if unexperienced) is unlikely to notice it if Gnome
CPU Frequency Scaling Monitor is not installed, I became aware of the problem
only after my laptop suddenly shut-down three times in a hour due to overheating.

I understand speedstep-smi has been compiled in the kernel for the convenience
of users of more modern processors and I can live with that. It would be nice
however if there was a way to prevent the kernel from loading it, because I'm
now forced to compile my own kernel and some of the kernel modules I need.

Regards,

Paolo

Note You need to log in before you can comment on or make changes to this bug.