Bug 205170 - Resume fails using 'nv' driver, but not using 'nvidia' driver
Resume fails using 'nv' driver, but not using 'nvidia' driver
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-05 02:35 EDT by Rodd Clarkson
Modified: 2008-04-05 19:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 19:20:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file (1.18 KB, text/plain)
2007-03-06 20:44 EST, Rodd Clarkson
no flags Details
Initial Xorg.0.log file before restarting and using 'nv' driver (42.93 KB, text/plain)
2007-03-06 20:46 EST, Rodd Clarkson
no flags Details
Initial Xorg.0.log.old file before restarting and using 'nv' driver (23.82 KB, text/plain)
2007-03-06 20:47 EST, Rodd Clarkson
no flags Details
Second Xorg.0.log file after restarting and using 'nv' driver. (42.88 KB, text/plain)
2007-03-06 20:50 EST, Rodd Clarkson
no flags Details
Second Xorg.0.log.old file after restarting and using 'nv' driver. (42.90 KB, text/plain)
2007-03-06 20:51 EST, Rodd Clarkson
no flags Details
Third Xorg.0.log file after restarting after failure to resume. (43.28 KB, text/plain)
2007-03-06 20:54 EST, Rodd Clarkson
no flags Details
Third Xorg.0.log file after restarting after failure to resume. (42.90 KB, text/plain)
2007-03-06 20:56 EST, Rodd Clarkson
no flags Details

  None (edit)
Description Rodd Clarkson 2006-09-05 02:35:49 EDT
Description of problem:

After suspending my system, it fails to resume.  It starts the resume process,
but then stops.  The screen never 'lights up' and the keyboard seems to be
frozen (caps lock doesn't toggle the light).

I thought this was a kernel issue, but now think it's actually related to the
xorg-x11-drv-nv driver.

Suspend and resume works fine with the proprietary 'nvidia' driver (supplied
through livna) but when I'm using the nv driver it doesn't resume.  I noticed
this because use the fedora-update-testing for FC5 and I noticed I have problems
with suspend and resume with the kernels when they are being tested.  I was
talking to davej about this and then noticed that a test kernel that wasn't
resuming suddenly started to work properly after installing a (rarely supplier)
kmod-nvidia package for the testing kernel (usually livna sticks to stable
releases only) and then I realized that the resume problem wasn't the kernel, it
was the xorg driver I was using (since nothing else had changed).

Version-Release number of selected component (if applicable):

kernel-2.6.17-1.2174_FC5
xorg-x11-drv-nv-1.2.0-3.fc5
kmod-nvidia-1.0.8774-1.2.6.17_1.2174_FC5

This has been seen with earlier versions of the linva kmod-nvidia driver (and
related packages).   It's also been seen with a range of kernels too.  Can't
tell you whether this was a problem with earlier versions of xorg-x11-drv-nv.

How reproducible:

Very


Steps to Reproduce:
1.  Start x with the 'nv' driver and it won't resume.
Comment 1 Rodd Clarkson 2006-09-12 20:10:24 EDT
It turns out that what I thought was a updates-testing kernel, was actually just
an 'updates' kernel, but it doesn't really change the nature of this bug report.
Comment 2 Matěj Cepl 2006-12-22 14:01:40 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Be also aware that Red Hat cannot support drivers which it doesn't provide,
which includes nvidia binary-only driver from livna, so please report all
information using only nv driver and make sure that neither service nvidia runs
(service nvidia status), nor that there is present kernel module nvidia (i.e.,
lsmod | grep nvidia gives nothing).

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Rodd Clarkson 2007-02-26 18:26:21 EST
Sorry about the slow reply.  I'll try to get this information to you as soon as
possible.  I'm no longer using FC5, so I'll have to test in FC6 and FC7.  I
haven't used the nv driver in FC6 for some time now, and suspend/resume isn't
working in FC7 for me, but since I can't use the nvidia driver to test I can't
tell you whether this is something to do with the nv driver, or whether
suspend/resume is more generally borked.
Comment 4 Matěj Cepl 2007-03-02 13:07:08 EST
Don't worry about nvidia driver -- I would close you the bug as CANTFIX if you
use it anyway.
Comment 5 Rodd Clarkson 2007-03-06 06:14:31 EST
Okay, this is still borked in FC7t2.

If I use the nv driver, FC7t2 does NOT resume after suspending.
If I use the nvidia driver, FC7t2 does resume.

I know you guys are not interested in the nvidia driver, but to be honest, it's
hard to give the nv driver any serious testing if each time I shut my laptop
lid, it suspends and then I have to force a reboot.

I'll try to get you the information you require regarding this ASAP.

Comment 6 Rodd Clarkson 2007-03-06 20:44:11 EST
Created attachment 149411 [details]
xorg.conf file
Comment 7 Rodd Clarkson 2007-03-06 20:46:04 EST
Created attachment 149412 [details]
Initial Xorg.0.log file before restarting and using 'nv' driver
Comment 8 Rodd Clarkson 2007-03-06 20:47:50 EST
Created attachment 149413 [details]
Initial Xorg.0.log.old file before restarting and using 'nv' driver
Comment 9 Rodd Clarkson 2007-03-06 20:50:30 EST
Created attachment 149414 [details]
Second Xorg.0.log file after restarting and using 'nv' driver.

This time when I tried to suspend, X crashed and threw me back to the log in
prompt.
Comment 10 Rodd Clarkson 2007-03-06 20:51:26 EST
Created attachment 149415 [details]
Second Xorg.0.log.old file after restarting and using 'nv' driver.
Comment 11 Rodd Clarkson 2007-03-06 20:54:49 EST
Created attachment 149416 [details]
Third Xorg.0.log file after restarting after failure to resume.

After a failure to resume I restarted in init 3 so that I didn't have X run.
Comment 12 Rodd Clarkson 2007-03-06 20:56:16 EST
Created attachment 149417 [details]
Third Xorg.0.log file after restarting after failure to resume.
Comment 13 Rodd Clarkson 2007-03-06 20:59:11 EST
Is this what you're after?
Comment 14 Adam Jackson 2007-03-08 11:01:20 EST
Is the machine still alive when you try to suspend?  IE, can you ping it from
the network, ssh in, etc.  If so this might just be failure to turn the
backlight on.
Comment 15 Rodd Clarkson 2007-03-13 19:33:06 EDT
I haven't had time to test whether I can ping the machine but will try to do so.

What I can tell you is the the keyboard also stops responding.  The caps lock
and num lock no longer show signs of toggling and pressing key combinations like
<CTRL><ALT><DEL> and <CTRL><ALT><BKSP> don't reboot the system, or restart X (or
show any signs of hard disk activity.

I'll still try the ping thing, but the only response I can get from the system
(without another machine, if that works) is to hold the OFF/ON button until it
reboots.
Comment 16 Bug Zapper 2008-04-03 14:08:37 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Note You need to log in before you can comment on or make changes to this bug.