Bug 205254 - Starting system message bus: Unknown username "named" in message bus configuration file
Summary: Starting system message bus: Unknown username "named" in message bus configur...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcdbd   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-05 15:56 UTC by Ronald Warsow
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 20:09:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current service configuration (1.44 KB, application/octet-stream)
2006-09-05 15:56 UTC, Ronald Warsow
no flags Details

Description Ronald Warsow 2006-09-05 15:56:49 UTC
Description of problem:
Starting system message bus: Unknown username "named" in message bus
configuration file


Version-Release number of selected component (if applicable):
dbus-0.92-1.fc6
dhcdbd-1.16-1.fc6

How reproducible:
service messagebus restart

Steps to Reproduce:
1.service messagebus restart
2.
3.
  
Actual results:
Unknown username "named" in message bus configuration file

Expected results:
no error

Additional info:
this is a new installed system (last sunday)
check against FC5 /etc/password gives no *named* entry under FC6, but user named
is mentioned in
/etc/dbus-1/system.d/dhcdbd.conf:10:    <policy user="named">

my changes since installation:
- switched off some services, but IIRC the messages apears just after fresh  
installation.
- selinux off
- audit off
- updates since sunday

Comment 1 Ronald Warsow 2006-09-05 15:56:49 UTC
Created attachment 135578 [details]
current service configuration

Comment 2 John (J5) Palmieri 2006-09-05 17:04:25 UTC
reassign to dhcdbd

Comment 3 Matthias Clasen 2006-09-05 17:10:31 UTC
bind does

%pre
if [ "$1" -eq 1 ]; then
   /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
   /usr/sbin/useradd  -u %{bind_uid} -r -n -M -g named -s /sbin/nologin -d
/var/named -c Named named >/dev/null 2>&1 || :;
fi;
:;

Comment 4 David Cantrell 2006-09-26 20:09:39 UTC
bind creates the named user account, but I don't know if dhcdbd needs to have a
policy for the named user.  It makes no sense to me, so I'm removing the policy
section in dhcdbd.conf for the named user.

Fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.