Bug 205260 - Nautlis conflicts with nautilus - multilib issue?
Nautlis conflicts with nautilus - multilib issue?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-05 12:18 EDT by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 09:40:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2006-09-05 12:18:59 EDT
Description of problem:
When upgrading nautilus I get the following:

Transaction Check Error:   file
/etc/gconf/schemas/apps_nautilus_preferences.schemas from install of
nautilus-2.16.0-1.fc6 conflicts with file from package nautilus-2.15.4-3
  file /usr/share/applications/gnome-nautilus-computer.desktop from install of
nautilus-2.16.0-1.fc6 conflicts with file from package nautilus-2.15.4-3
  file /usr/share/applications/gnome-nautilus-file-management-properties.desktop
from install of nautilus-2.16.0-1.fc6 conflicts with file from package
nautilus-2.15.4-3
  file /usr/share/applications/gnome-nautilus-folder-handler.desktop from
install of nautilus-2.16.0-1.fc6 conflicts with file from package nautilus-2.15.4-3
  file /usr/share/applications/gnome-nautilus-home.desktop from install of
nautilus-2.16.0-1.fc6 conflicts with file from package nautilus-2.15.4-3
  file /usr/share/applications/gnome-nautilus.desktop from install of
nautilus-2.16.0-1.fc6 conflicts with file from package nautilus-2.15.4-3
  file /usr/share/applications/gnome-network-scheme.desktop from install of
nautilus-2.16.0-1.fc6 conflicts with file from package nautilus-2.15.4-3
  file /usr/share/mime/packages/nautilus.xml from install of
nautilus-2.16.0-1.fc6 conflicts with file from package nautilus-2.15.4-3
  file /usr/share/nautilus/glade/nautilus-file-management-properties.glade from
install of nautilus-2.16.0-1.fc6 conflicts with file from package nautilus-2.15.4-3


Version-Release number of selected component (if applicable):
nautilus-2.16.0-1.fc6 

How reproducible:
100%

Additional info:
AMD64 X2, da_DK.UTF-8
Comment 1 Matthias Clasen 2006-09-05 12:58:23 EDT
I added a %preun to uninstall schemas. I think that should fix this problem.
Comment 2 David Nielsen 2006-09-20 15:53:22 EDT
I'm still seeing this with 2.16.0-4.fc6, reopening.
Comment 3 Alexander Larsson 2006-09-21 09:14:15 EDT
How exactly are you installing the new nautilus. Which version of nautilus do
you have installed already?

It seems to me like you're installing only a 64bit nautilus, and you have an
older nautilus in both 32bit and 64bit version installed.
Comment 4 David Nielsen 2006-09-21 09:25:42 EDT
ah mea culpa.. you are entirely right

rpm reports:
nautilus-2.15.4-3
nautilus-2.16.0-4.fc6

In my effort to track down another nautilus issue I force upgraded the x86_64
rpm since yum update failed.. I keep forgetting the hell that is multilib.

many apologies
Comment 5 Alexander Larsson 2006-09-21 09:40:02 EDT
Closing then.
Comment 6 David Timms 2006-10-18 10:23:28 EDT
Another data point. I installed fc6t3 x86_64 last week {default selections}, and
then nautilus-open-temrinal, and then did yum update. This was unable to
complete due to the same Transaction check error listed above. I then unselected
the nautilus packages from pup and let the machine update everything else, which
succeeds. However, the nautilus package is still unable to update with the same
message as shown above.

# grep -E 'naut|kernel' /var/log/yum.log 
Oct 13 21:10:16 Installed: nautilus-open-terminal.x86_64 0.7-3.fc6
Oct 13 23:03:17 Installed: kernel-devel.x86_64 2.6.18-1.2768.fc6
Oct 13 23:10:13 Installed: kernel-headers.x86_64 2.6.18-1.2768.fc6
Oct 13 23:23:51 Installed: kernel.x86_64 2.6.18-1.2768.fc6
Oct 13 23:28:10 Updated: nautilus-cd-burner.x86_64 2.16.0-3.fc6
Oct 13 23:28:17 Updated: nautilus-cd-burner.i386 2.16.0-3.fc6
Oct 13 23:31:11 Updated: nautilus-sendto.x86_64 0.7-5.fc6
Oct 15 14:39:21 Updated: kernel-headers.x86_64 2.6.18-1.2784.fc6
Oct 15 14:40:08 Installed: kernel.x86_64 2.6.18-1.2784.fc6
Oct 15 14:40:30 Installed: kernel-devel.x86_64 2.6.18-1.2784.fc6

# rpm -qa --queryformat "%{NAME}#%{ARCH}#%{VERSION}#%{RELEASE}\n" |grep -E
'kernel|nautilus'|sort
kernel-devel#x86_64#2.6.18#1.2768.fc6
kernel-devel#x86_64#2.6.18#1.2784.fc6
kernel-headers#x86_64#2.6.18#1.2784.fc6
kernel#x86_64#2.6.18#1.2768.fc6
kernel#x86_64#2.6.18#1.2784.fc6
nautilus-cd-burner#i386#2.16.0#3.fc6
nautilus-cd-burner#x86_64#2.16.0#3.fc6
nautilus#i386#2.15.4#3
nautilus-open-terminal#x86_64#0.7#3.fc6
nautilus-sendto#x86_64#0.7#5.fc6
nautilus#x86_64#2.15.4#3

As Alex guesses, there is i386 and x86_64 nautilus and nautilus-cd-burner
packages installed. 

From the install.log:
...
Installing gnome-panel - 2.14.2-8.i386
Installing gcalctool - 5.8.17-1.x86_64
Installing gnome-vfs2-smb - 2.15.3-7.x86_64
Installing nautilus - 2.15.4-3.i386
Installing libgsf - 1.14.1-6.x86_64
Installing librsvg2 - 2.15.0-3.1.x86_64
Installing nautilus - 2.15.4-3.x86_64
Installing control-center - 1:2.15.4-6.x86_64
Installing xorg-x11-drv-keyboard - 1.1.0-2.1.x86_64
Installing nautilus-cd-burner - 2.15.4-3.x86_64
Installing gsf-sharp - 0.8-1.1.x86_64
Installing nautilus-cd-burner - 2.15.4-3.i386
Installing gstreamer-plugins-base - 0.10.9-4.i386
Installing gnome-media - 2.14.2-6.i386
Installing gnome-netstatus - 2.12.0-5.1.x86_64
Installing gnome-pilot - 2.0.13-13.1.x86_64
Installing gtkhtml3 - 3.11.90.1-1.x86_64
Installing gthumb - 2.7.7-4.x86_64
Installing gnome-volume-manager - 1.5.15-4.x86_64
Installing gnome-spell - 1.0.7-3.1.x86_64
Installing evolution - 2.7.4-4.x86_64
Installing evolution-sharp - 0.11.1-5.1.x86_64
Installing firefox - 1.5.0.5-8.x86_64
Installing gtk-sharp - 1.0.10-6.1.x86_64
Installing yum-metadata-parser - 1.0-7.1.fc6.x86_64
Installing tomboy - 0.3.5-7.x86_64
Installing yelp - 2.15.5-1.x86_64
Installing beagle - 0.2.7-6.x86_64
Installing gnome-session - 2.15.4-2.x86_64
Installing gnome-media - 2.14.2-6.x86_64
Installing file-roller - 2.15.1-2.x86_64
Installing evince - 0.5.4-3.x86_64
Installing nautilus-sendto - 0.7-1.1.x86_64
Installing gdm - 1:2.15.6-14.fc6.x86_64
...
So anaconda installed both i386 and x86_64 versions.

And there has been an updated nautilus in the development repo:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/x86_64/os/Fedora/RPMS/nautilus-2.16.0-5.fc6.x86_64.rpm
but a matching i386 version has not been built, and would seem to be the cause
of this error.

# yum remove nautilus.i386
...
 Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
 nautilus                i386       2.15.4-3         installed          12 M
Removing for dependencies:
 control-center          i386       1:2.16.0-9.fc6   installed         8.1 M
 gnome-media             i386       2.16.1-2.fc6     installed         5.2 M
 nautilus-cd-burner      i386       2.16.0-3.fc6     installed         1.7 M

1. Should there be an updated nautilus.i386 ?
2. Is it required to remove these i386 packages that were installed by anaconda ?
3. Has there been an update to anaconda/package selection so that the above no
longer occurs ?

Comment 7 Alexander Larsson 2006-10-19 04:43:58 EDT
If you have an i386 nautilus then yum is supposed to upgrade that too, which
should avoid the conflict. I wonder why that isn't happening. Maybe
nautilus.i386 was removed from the x86-64 repository?

Note You need to log in before you can comment on or make changes to this bug.