Bug 205302 - fatal error when selecting File -> Import
Summary: fatal error when selecting File -> Import
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
: 205817 206115 209550 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-05 21:57 UTC by Luke Macken
Modified: 2016-09-20 02:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-12 15:48:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luke Macken 2006-09-05 21:57:09 UTC
After todays rawhide upgrade to f-spot-0.2.0-1.fc6, I'm getting the following
stracktrace when opening f-spot, and clicking File -> Import.

An unhandled exception was thrown: libgphoto2_port.so

  at (wrapper managed-to-native) LibGPhoto2.PortInfoList:gp_port_info_list_new
(intptr&)
  at LibGPhoto2.PortInfoList..ctor () [0x00000] 
  at GPhotoCamera..ctor () [0x00000] 
  at ImportCommand+SourceMenu..ctor (.ImportCommand command) [0x00000] 
  at ImportCommand.ImportFromFile (.PhotoStore store, System.String path) [0x00000] 
  at MainWindow.HandleImportCommand (System.Object sender, System.EventArgs e)
[0x00000] 
  at (wrapper delegate-invoke)
System.MulticastDelegate:invoke_void_object_EventArgs (object,System.EventArgs)
  at GLib.Signal.voidObjectCallback (IntPtr handle, IntPtr gch) [0x00000] 
  at (wrapper native-to-managed) GLib.Signal:voidObjectCallback (intptr,intptr)
  at <0x00000> <unknown method>
  at (wrapper managed-to-native) Gtk.Application:gtk_main ()
  at Gtk.Application.Run () [0x00000] 
  at Gnome.Program.Run () [0x00000] 
  at FSpot.Driver.Main (System.String[] args) [0x00000] 
.NET Version: 1.1.4322.2032

Assembly Version Information:

libgphoto2-sharp (1.0.2438.34349)
FlickrNet (1.1.0.0)
gconf-sharp (2.16.0.0)
pango-sharp (2.10.0.0)
SemWeb (0.5.0.2)
glade-sharp (2.10.0.0)
gtkhtml-sharp (2.16.0.0)
System.Data (1.0.5000.0)
Mono.Data.SqliteClient (1.0.5000.0)
gdk-sharp (2.10.0.0)
gnome-vfs-sharp (2.16.0.0)
dbus-sharp (0.60.0.0)
System (1.0.5000.0)
Mono.Posix (1.0.5000.0)
atk-sharp (2.10.0.0)
gtk-sharp (2.10.0.0)
glib-sharp (2.10.0.0)
gnome-sharp (2.16.0.0)
f-spot (0.0.0.0)
mscorlib (1.0.5000.0)

Platform Information: Linux 2.6.17-1.2617.2.1.fc6 i686 i386 GNU/Linux

Disribution Information:

[/etc/redhat-release]
Fedora Core release 5.91 (FC6 Test2)

[/etc/fedora-release]
Fedora Core release 5.91 (FC6 Test2)

Comment 1 Pavel Rosenboim 2006-09-09 16:18:05 UTC
gphoto2-devel need to be installed to get f-spot import working. It should be
made a dependancy of an f-spot package.

Comment 2 Matthias Clasen 2006-09-09 18:16:11 UTC
That probably indicates that we need to fix some mono dlls to depend on the
versioned libraries rather than the unversioned .so

Comment 3 Matthias Clasen 2006-09-11 15:00:33 UTC
*** Bug 205817 has been marked as a duplicate of this bug. ***

Comment 4 Matthias Clasen 2006-09-12 15:48:17 UTC
Should be fixed in 0.2.0-2.fc6

Comment 5 Christopher Aillon 2006-10-29 19:11:57 UTC
*** Bug 206115 has been marked as a duplicate of this bug. ***

Comment 6 Christopher Aillon 2006-10-29 19:12:07 UTC
*** Bug 209550 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.