Bug 205527 - up2date-config fails to set serverUrl ..
up2date-config fails to set serverUrl ..
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clifford Perry
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 17:23 EDT by Gurhan Ozen
Modified: 2013-11-03 20:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 12:05:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2006-09-06 17:23:58 EDT
Description of problem:
I tried to set serverUrl using up2date-config on RHEL 4.4 but it gave me
following error:

Enter number of item to edit <return to exit, q to quit without saving>: 28

Attribute: serverURL
current value: https://xmlrpc.rhn.redhat.com/XMLRPC
1: https://xmlrpc.rhn.redhat.com/XMLRPC
   < enter number of choice to use, return for default>:
https://xmlrpc.rhn.webqa.redhat.com/XMLRPC

There was an error
exceptions.UnboundLocalError local variable 'intvalue' referenced before assignment

Version-Release number of selected component (if applicable):
# up2date --version
Red Hat Update Agent v4.4.69-25
Copyright (C) 1999-2002 Red Hat, Inc.
Licensed under terms of the GPL.
# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 4)


How reproducible:
Very.

Steps to Reproduce:
1. Just run up2date-config and try to set serverUrl value to something else. 
2.
3.
  
Actual results:
Gives the error above.

Expected results:
Should work.

Additional info:
Workaround is to edit /etc/sysconfig/rhn/up2date file, which has worked for me.
Comment 1 Red Hat Bugzilla 2007-04-11 21:10:57 EDT
User bnackash@redhat.com's account has been closed
Comment 2 Jiri Pallich 2012-06-20 12:05:50 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.