Bug 205540 - Reading http://www.lovesunix.net/spaceoptimization.pdf, evince crashes
Reading http://www.lovesunix.net/spaceoptimization.pdf, evince crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 22:14 EDT by sangu
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: fontconfig-2.4.0-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 11:00:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evince backtrace full file. (8.92 KB, text/plain)
2006-09-06 22:14 EDT, sangu
no flags Details

  None (edit)
Description sangu 2006-09-06 22:14:44 EDT
Description of problem:
Reading ( http://www.lovesunix.net/spaceoptimization.pdf ), evince crashes

[sangu@localhost ~]$ gdb evince
GNU gdb Red Hat Linux (6.5-7.fc6rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

(gdb) r
Starting program: /usr/bin/evince 
[Thread debugging using libthread_db enabled]
[New Thread -1208371488 (LWP 4290)]
[New Thread -1211958384 (LWP 4293)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208371488 (LWP 4290)]
0x009079b4 in FcPatternPosition (p=0xb674719c, object=<value optimized out>)
    at fcint.h:838
838         return a - b;
(gdb) bt
#0  0x009079b4 in FcPatternPosition (p=0xb674719c, 
    object=<value optimized out>) at fcint.h:838
#1  0x00907a17 in FcPatternFindElt (p=0xb674719c, object=0x91225f "charset")
    at fcpat.c:739
#2  0x009090c6 in FcPatternGet (p=0xb674719c, object=0x91225f "charset", id=0, 
    v=0xbf914738) at fcpat.c:1154
#3  0x00909402 in FcPatternGetCharSet (p=0xb674719c, 
    object=0x91225f "charset", id=0, c=0xbf914800) at fcpat.c:1272
#4  0x00904ae3 in FcFontSetSort (config=0x84d56a8, sets=0xbf91484c, nsets=1, 
    p=0x85b63b0, trim=1, csp=0x0, result=0xbf9149c4) at fcmatch.c:802
#5  0x00904e34 in FcFontSort (config=0xf24, p=0x85b63b0, trim=1, csp=0x0, 
    result=0xbf9149c4) at fcmatch.c:1039
#6  0x004f9a0e in pango_fc_font_map_load_fontset (fontmap=0x8414de8, 
    context=0x8618020, desc=0x8618080, language=0x84ce560)
    at pangofc-fontmap.c:1055
#7  0x009c6c90 in pango_font_map_load_fontset (fontmap=0x8414de8, 
    context=0x8618020, desc=0x8618080, language=0x84ce560)
    at pango-fontmap.c:107
#8  0x009c4d12 in itemize_state_process_run (state=0xbf914a94)
    at pango-context.c:1045
#9  0x009c5052 in pango_itemize_with_base_dir (context=0x8618020, 
    base_dir=PANGO_DIRECTION_LTR, text=0x86141d8 "1", start_index=0, length=1, 
    attrs=0x85ff270, cached_iter=0x85ff2c0) at pango-context.c:1196
---Type <return> to continue, or q <return> to quit---
#10 0x009ccf91 in pango_layout_check_lines (layout=0x857f520)
    at pango-layout.c:3328
#11 0x009cdb6c in pango_layout_get_extents_internal (layout=0x857f520, 
    ink_rect=0x0, logical_rect=0xbf914d58, line_extents=0x0)
    at pango-layout.c:2064
#12 0x009ceb3d in pango_layout_get_pixel_extents (layout=0x857f520, 
    ink_rect=0x0, logical_rect=0xbf914d58) at pango-layout.c:2257
#13 0x00fdaad1 in get_size (cell=0x84cec28, widget=0x8564130, cell_area=0x0, 
    layout=0x857f520, x_offset=0x0, y_offset=0x0, width=0x842c978, 
    height=0x842c97c) at gtkcellrenderertext.c:1520
#14 0x00fd3a64 in IA__gtk_cell_renderer_get_size (cell=0x84cec28, 
    widget=0x8564130, cell_area=0x0, x_offset=0x0, y_offset=0x0, 
    width=0x842c978, height=0x842c97c) at gtkcellrenderer.c:507
#15 0x01066d66 in gtk_icon_view_calculate_item_size (icon_view=0x8564130, 
    item=0x85cb790) at gtkiconview.c:2705
#16 0x0106b4be in gtk_icon_view_layout (icon_view=0x8564130)
    at gtkiconview.c:2547
#17 0x0106b52a in layout_callback (user_data=0x8564130) at gtkiconview.c:3076
#18 0x006e75e1 in g_idle_dispatch (source=0x85cb530, callback=0x10, 
    user_data=0x8564130) at gmain.c:3926
#19 0x006e9342 in IA__g_main_context_dispatch (context=0x8417a60)
    at gmain.c:2045
#20 0x006ec31f in g_main_context_iterate (context=0x8417a60, block=1, 
---Type <return> to continue, or q <return> to quit---
    dispatch=1, self=0x83f7ec8) at gmain.c:2677
#21 0x006ec6c9 in IA__g_main_loop_run (loop=0x84b1050) at gmain.c:2881
#22 0x01094c04 in IA__gtk_main () at gtkmain.c:1001
#23 0x0807a660 in main (argc=1, argv=Cannot access memory at address 0xf28
) at main.c:345
#24 0x06223f2c in __libc_start_main (main=0x807a0f0 <main>, argc=1, 
    ubp_av=0xbf915154, init=0x809a98c <__libc_csu_init>, 
    fini=0x809a984 <__libc_csu_fini>, rtld_fini=0xde2380 <_dl_fini>, 
(gdb) bt
#0  0x009079b4 in FcPatternPosition (p=0xb674719c, 
    object=<value optimized out>) at fcint.h:838
#1  0x00907a17 in FcPatternFindElt (p=0xb674719c, object=0x91225f "charset")
    at fcpat.c:739
#2  0x009090c6 in FcPatternGet (p=0xb674719c, object=0x91225f "charset", id=0, 
    v=0xbf914738) at fcpat.c:1154
#3  0x00909402 in FcPatternGetCharSet (p=0xb674719c, 
    object=0x91225f "charset", id=0, c=0xbf914800) at fcpat.c:1272
#4  0x00904ae3 in FcFontSetSort (config=0x84d56a8, sets=0xbf91484c, nsets=1, 
    p=0x85b63b0, trim=1, csp=0x0, result=0xbf9149c4) at fcmatch.c:802
#5  0x00904e34 in FcFontSort (config=0xf24, p=0x85b63b0, trim=1, csp=0x0, 
    result=0xbf9149c4) at fcmatch.c:1039
#6  0x004f9a0e in pango_fc_font_map_load_fontset (fontmap=0x8414de8, 
    context=0x8618020, desc=0x8618080, language=0x84ce560)
    at pangofc-fontmap.c:1055
#7  0x009c6c90 in pango_font_map_load_fontset (fontmap=0x8414de8, 
    context=0x8618020, desc=0x8618080, language=0x84ce560)
    at pango-fontmap.c:107
#8  0x009c4d12 in itemize_state_process_run (state=0xbf914a94)
    at pango-context.c:1045
#9  0x009c5052 in pango_itemize_with_base_dir (context=0x8618020, 
    base_dir=PANGO_DIRECTION_LTR, text=0x86141d8 "1", start_index=0, length=1, 
    attrs=0x85ff270, cached_iter=0x85ff2c0) at pango-context.c:1196
---Type <return> to continue, or q <return> to quit---
#10 0x009ccf91 in pango_layout_check_lines (layout=0x857f520)
    at pango-layout.c:3328
#11 0x009cdb6c in pango_layout_get_extents_internal (layout=0x857f520, 
    ink_rect=0x0, logical_rect=0xbf914d58, line_extents=0x0)
    at pango-layout.c:2064
#12 0x009ceb3d in pango_layout_get_pixel_extents (layout=0x857f520, 
    ink_rect=0x0, logical_rect=0xbf914d58) at pango-layout.c:2257
#13 0x00fdaad1 in get_size (cell=0x84cec28, widget=0x8564130, cell_area=0x0, 
    layout=0x857f520, x_offset=0x0, y_offset=0x0, width=0x842c978, 
    height=0x842c97c) at gtkcellrenderertext.c:1520
#14 0x00fd3a64 in IA__gtk_cell_renderer_get_size (cell=0x84cec28, 
    widget=0x8564130, cell_area=0x0, x_offset=0x0, y_offset=0x0, 
    width=0x842c978, height=0x842c97c) at gtkcellrenderer.c:507
#15 0x01066d66 in gtk_icon_view_calculate_item_size (icon_view=0x8564130, 
    item=0x85cb790) at gtkiconview.c:2705
#16 0x0106b4be in gtk_icon_view_layout (icon_view=0x8564130)
    at gtkiconview.c:2547
#17 0x0106b52a in layout_callback (user_data=0x8564130) at gtkiconview.c:3076
#18 0x006e75e1 in g_idle_dispatch (source=0x85cb530, callback=0x10, 
    user_data=0x8564130) at gmain.c:3926
#19 0x006e9342 in IA__g_main_context_dispatch (context=0x8417a60)
    at gmain.c:2045
#20 0x006ec31f in g_main_context_iterate (context=0x8417a60, block=1, 
---Type <return> to continue, or q <return> to quit---
    dispatch=1, self=0x83f7ec8) at gmain.c:2677
#21 0x006ec6c9 in IA__g_main_loop_run (loop=0x84b1050) at gmain.c:2881
#22 0x01094c04 in IA__gtk_main () at gtkmain.c:1001
#23 0x0807a660 in main (argc=1, argv=Cannot access memory at address 0xf28
) at main.c:345
#24 0x06223f2c in __libc_start_main (main=0x807a0f0 <main>, argc=1, 
    ubp_av=0xbf915154, init=0x809a98c <__libc_csu_init>, 
    fini=0x809a984 <__libc_csu_fini>, rtld_fini=0xde2380 <_dl_fini>, 
    stack_end=0xbf91514c) at libc-start.c:231
#25 0x08057491 in _start ()

Version-Release number of selected component (if applicable):
0.6.0-1.fc6

How reproducible:
always

Steps to Reproduce:
1. evince
2. open spaceoptimization.pdf
3.
  
Actual results:


Expected results:


Additional info:
fontconfig-2.3.95-11.fc6
poppler-0.5.3-2.fc6
pango-1.14.3-1.fc6
cairo-1.2.4-1.fc6
Comment 1 sangu 2006-09-06 22:14:44 EDT
Created attachment 135713 [details]
evince backtrace full file.
Comment 2 Matthias Clasen 2006-09-10 16:07:44 EDT
that pdf works fine on my system with fontconfig 2.3.97.
either the problem is fixed in 2.3.97, or it depends on the
installed fonts...

Note You need to log in before you can comment on or make changes to this bug.