Bug 205586 - Problems installing both x86_64 and i686 openssl side by side
Problems installing both x86_64 and i686 openssl side by side
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssl (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-07 10:19 EDT by Aleksandar Milivojevic
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 15:34:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Milivojevic 2006-09-07 10:19:06 EDT
Description of problem:
I have an application that is 32-bit only and it requires openssl libraries. 
When installing openssl.i686, rpm complains about conflicting files from
openssl.x86_64 package:

# rpm -ihv openssl-0.9.7a-43.10.i686.rpm
Preparing...                ########################################### [100%]
        file /usr/share/man/man1/asn1parse.1ssl.gz from install of
openssl-0.9.7a-43.10 conflicts with file from package openssl-0.9.7a-43.10
        file /usr/share/man/man1/nseq.1ssl.gz from install of
openssl-0.9.7a-43.10 conflicts with file from package openssl-0.9.7a-43.10
        file /usr/share/man/man1/s_client.1ssl.gz from install of
openssl-0.9.7a-43.10 conflicts with file from package openssl-0.9.7a-43.10
        file /usr/share/man/man1/s_server.1ssl.gz from install of
openssl-0.9.7a-43.10 conflicts with file from package openssl-0.9.7a-43.10
        file /usr/share/man/man1/sslpasswd.1ssl.gz from install of
openssl-0.9.7a-43.10 conflicts with file from package openssl-0.9.7a-43.10

I can force installation of openssl.i686, and all is good (conflicting files are
manpages, and should be identical anyhow).

It would be nice if packaging of openssl would allow more smooth installation of
both 32-bit and 64-bit version of package.

Version-Release number of selected component (if applicable):
openssl-0.9.7a-43.10

How reproducible:
Always

Steps to Reproduce:
1. Install x86_64 version of openssl (should be already there in default install)
2. Attempt to install i686 version of openssl in parallel to x86_64 version
  
Actual results:


Expected results:


Additional info:
Comment 1 Tomas Mraz 2006-09-07 13:54:27 EDT
I can't reproduce this problem here. If you're using a RHEL4 subscription,
please use your support account to report the problem so it can be properly
investigated and resolved. You can mention this bug report number there.
Comment 2 Aleksandar Milivojevic 2006-09-08 13:19:02 EDT
Uf, uh... wrong distro.  I was testing on my devel box (which is a clone).  EL4
packages seems to work fine.

Note You need to log in before you can comment on or make changes to this bug.