Bug 205591 - Multipath not creating partitions. (SERIAL_SIZE overflow discovery.c/structs.h)
Multipath not creating partitions. (SERIAL_SIZE overflow discovery.c/structs.h)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Marzinski
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-07 10:37 EDT by Jose Plans
Modified: 2010-01-11 21:27 EST (History)
12 users (show)

See Also:
Fixed In Version: RHEA-2007-0256
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:43:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch avoiding the overflow. (1010 bytes, patch)
2006-09-07 10:37 EDT, Jose Plans
no flags Details | Diff
[reproduce] device creation and errors. (4.73 KB, text/plain)
2006-09-07 10:42 EDT, Jose Plans
no flags Details

  None (edit)
Description Jose Plans 2006-09-07 10:37:43 EDT
Description of problem:
serial length not reset if higher than the SERIAL_SIZE, causing overflow, making
the partitions to file during their creation.

Version-Release number of selected component (if applicable):
 device-mapper-multipath-0.4.5-16.1.RHEL4

How reproducible:
 Always.

Steps to Reproduce:
1. attached txt file.
  
Actual results:
Customer can't create partitions.

Expected results:
Partitions are created correctly.

Additional info:
[PATCH attached, although upstream fixed this already]
Comment 1 Jose Plans 2006-09-07 10:37:43 EDT
Created attachment 135768 [details]
Patch avoiding the overflow.
Comment 2 Jose Plans 2006-09-07 10:42:54 EDT
Created attachment 135770 [details]
[reproduce] device creation and errors.
Comment 3 Ben Marzinski 2006-09-15 17:50:12 EDT
This is now fixed.
Comment 5 Ivan Szanto 2007-01-26 05:13:23 EST
We have a problem caused by the same bug.

We have an external storage accessible by iSCSI (Promise VTRAK M200i). We have
been using it for a while with a 200GB volume we subdivide using LVM, and we
created some gfs partitions on it. It works fine without multipathing.

We decided to implement multipath in this environment.

After booting one of the computers with multipathing turned on, I see that only
2 out of our 10 logical volumes get mounted. Multipath output show only 2GB out
of the 200GB. 

It took me some hours to figure out that the problem is caused by this overflow
bug. Then it took me 15 minutes to find this bug in bugzilla.

Applying the patch (id=135768) fixes the problem, all the partitions are mounted
as without multipathing.

Please release a fixed rpm package ASAP.
Comment 9 Red Hat Bugzilla 2007-05-01 13:43:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0256.html

Note You need to log in before you can comment on or make changes to this bug.