Bug 20562 - Can't compile bind-8.2.2_P5-25 on RH7
Can't compile bind-8.2.2_P5-25 on RH7
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-09 03:26 EST by Garai Piter
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-09 11:16:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garai Piter 2000-11-09 03:26:23 EST
I get the following error message /I applied the glibc21.patch from the 
src.rpm/:

/usr/src/redhat/SOURCES/src/bin/nslookup/list.c:528: the use of `mktemp' 
is dangerous, better use `mkstemp'
../../lib/libbind.a(herror.o): In function `herror':
/usr/src/redhat/SOURCES/src/lib/resolv/herror.c:102: undefined reference 
to `__h_errno'
../../lib/libbind.a(res_data.o): In function `__res_mkquery':
/usr/src/redhat/SOURCES/src/lib/resolv/res_data.c:154: undefined reference 
to `__h_errno_set'
../../lib/libbind.a(res_data.o): In function `__res_mkupdate':
/usr/src/redhat/SOURCES/src/lib/resolv/res_data.c:165: undefined reference 
to `__h_errno_set'
../../lib/libbind.a(res_data.o): In function `__res_query':
/usr/src/redhat/SOURCES/src/lib/resolv/res_data.c:179: undefined reference 
to `__h_errno_set'
../../lib/libbind.a(res_data.o): In function `__res_update':
/usr/src/redhat/SOURCES/src/lib/resolv/res_data.c:230: undefined reference 
to `__h_errno_set'
../../lib/libbind.a(res_data.o): In function `__res_search':
/usr/src/redhat/SOURCES/src/lib/resolv/res_data.c:244: undefined reference 
to `__h_errno_set'
../../lib/libbind.a
(res_data.o):/usr/src/redhat/SOURCES/src/lib/resolv/res_data.c:259: more 
undefined references to `__h_errno_set' follow
collect2: ld returned 1 exit status
make[2]: *** [nslookup] Error 1
make[2]: Leaving directory `/usr/src/redhat/SOURCES/src/bin/nslookup'
make[1]: *** [nslookup] Error 2
make[1]: Leaving directory `/usr/src/redhat/SOURCES/src/bin'
make: *** [all] Error 2
make: Leaving directory `/usr/src/redhat/SOURCES/src'
Comment 1 Bernhard Rosenkraenzer 2000-11-10 04:41:41 EST
I can't reproduce this. Make sure you've applied the other patches (in particular the -rh patch), as well.

Note You need to log in before you can comment on or make changes to this bug.