Bug 205623 - Evolution no longer displays "On The Web" calendar events for a particular user.
Evolution no longer displays "On The Web" calendar events for a particular user.
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: evolution-webcal (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-07 13:45 EDT by Jake Gage
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 13:53:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jake Gage 2006-09-07 13:45:33 EDT
Description of problem:
Evolution no longer displays "On The Web" calendar events for a particular user.

Version-Release number of selected component (if applicable):
(~){dispader}11:43am] rpm -qa | grep evolution
evolution-data-server-1.6.3-1.fc5.2
evolution-sharp-0.10.2-9.5
evolution-connector-2.6.3-1.fc5.1
evolution-webcal-2.4.1-3.4
evolution-data-server-devel-1.6.3-1.fc5.2
evolution-devel-2.6.3-1.fc5.5
evolution-2.6.3-1.fc5.5

How reproducible:
Always.

Evolution, for my main user account, stopped displaying "On the Web" (iCal/vCal)
calendars without configuration change.  Removal, restarting (system, just to be
certain, in each of the tests), and addition of calendar components does not
correct the problem.

No debugging output is displayed from the Evolution application itself:

(~){dispader}12:29pm] evolution
CalDAV Eplugin starting up ...
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files

  Creating another user account and Gnome configuration allows the addition of
calendar resources.

  I'm willing (at this point) to keep my configuration for one more day, if
somebody can give me debugging instructions.  After that, I'll have to come up
with a solution for PIM managment.

  Sidenote (little bit of a rant, here):

  I consider it extremely bad form to rant in a bug report, but I'm reaching
wit's end with the Evolution suite.  If I have to track down all the locations
of Evolution configuration data, blow them away, and purge data from the
evolution data server, and re-import what I can...  Well, frankly I've had
enough, and I'd like to start asking the community to remove the Gnome
dependencies on the Evolution data server.

  I've stayed with this product for literally years and been a big advocate, but
I just don't know how much longer I'm willing to deal with just coming to work
on Monday and finding that I've lost historical and contact data.  This has been
six times over the years.  Backups, while a little better now with vcard export
(thank you guys), are still laberinthine.

  I don't feel like anybody owes me "support," but I'm starting to think that,
without at least some consession to make packaging and data storage a bit less
brittle in the architecture, it isn't wise to couch Evo as the default
PIM/calendar/email solution for Fedora as a whole.

  Okay, rant off.

  I know people are probably busy with the shore release, but if anybody in the
community could shoot me a link to debugging information, I'll hold
configuration and at least do some analysis on why remote cal data isn't getting
displayed.

  Thanks much.
Comment 1 Matthew Barnes 2006-09-07 16:39:48 EDT
Jake, Evolution 2.6 in Fedora Core 5 has probably seen it's last update.  But
Evolution 2.8 is in Rawhide now and will soon be in Fedora Core 6.  I encourage
you to try upgrading and see whether this problem still exists.

Debugging information, for use by debuggers like GDB, is available by installing
the -debuginfo variants of each package (e.g. evolution-debuginfo).  However I'm
not aware of any simple debugging procedures in or outside of GDB for something
like this.  Upgrading is probably best thing to try first.
Comment 2 Jake Gage 2006-09-07 16:45:42 EDT
Hey, Matt.  Thanks for the quick response, by the way.

Yeah, I've got the debuginfo packages installed, but I don't know how to attach
the GDB to Evolution or the data server (since the processes are started up
automatically).  It sounds like a moot point, though, if the 2.6 code is drying up.

So, are you suggesting that I enable the fedora-testing repository and upgrade
the Evolution packages via yum?  (Sorry to be asking, but I can't easily yank
the packages to install new libs due to the package dependencies.)

Damned end-users, huh?
Comment 3 Matthew Barnes 2006-09-07 17:09:04 EDT
Just FYI, to attach GDB to a process, you need to specify its numeric process ID
(pid).  Easiest way is to use the 'pidof' utility.

   $ /sbin/pidof evolution
   $ /sbin/pidof evolution-data-server-1.6

If you don't have that utility for some reason, the 'ps' command is another way:

   $ ps ax | grep evolution
   $ ps ax | grep evolution-data-server-1.6
   (The first number displayed is the process ID.)

Then just tell GDB which process ID to attach to:

   $ gdb --pid <process-id>   -or-
   $ gdb --pid `/sbin/pidof evolution`

Yum is definitely an easier way to upgrade than trying to do it by hand.  But be
warned that you'll probably pull in lots of extra dependencies, so you might
want to just upgrade your whole system to Rawhide.  Normally I wouldn't
recommend that, but we're on the brink of a new Fedora Core so things are pretty
stable at the moment.
Comment 4 Matthew Barnes 2006-09-07 17:11:38 EDT
I forgot to add, do all that stuff *after* starting Evolution as you normally
would.  The --pid option attaches to an already running process.
Comment 5 Jake Gage 2006-09-08 18:17:24 EDT
Hey Matt,

Thanks for the information on connecting the GDB.  FYI, the GDB attached to the
evolution process successfully.  Nice.  No errors get logged via debug (no
surprise there, and nothing disasterous happens in any of the outputs).  I
didn't try running a trace on the data server.

Anyhow, that was fun; but I think this is moot as far as this bug goes.  If it's
a problem in Evo 2.6, and 2.8 is in rawhide, this should probably just be marked
"wontfix".

I tried upgrading packages to rawhide, which I suppose is still useful in bug
tracking if the data problem persists after I upgrade; but was getting messages
about missing library dependencies through yum.  I'll give it a go and give
detail here.

Jake
Comment 6 Jake Gage 2006-09-12 01:26:56 EDT
All right.  It doesn't appear that I can upgrade to the FC6 packages for
Evolution via the Rawhide yum repositories.  It appears that, currently, I get
the message that bind-config 9.3.2-20 requires bind 9.3.2-20.  Currently, the
most recent update in fedora-updates is bind 9.3.2-33.

Could be this is also a resolver dependency for bind.  I'll try to roll back to
bind 9.3.2-20.

I've tried to roll out bind, but that entails rolling out NetworkManager (and
all NetworkManager-<foo>, which involves removing... you guessed it... Evolution).

Which is required by Gnome.  Yie.
Comment 7 Jake Gage 2006-09-12 01:33:21 EDT
Nevermind... the bind-9.3.2-20 dependency goes back to kerberos libs.
Comment 8 Jake Gage 2006-09-12 01:50:15 EDT
All right.  Force installing the bind 9.3.2-20 (while keeping bind 9.3.2-33)
made the system able to resolve the dependencies.  I guess if you hear back from
me tomorrow, you'll know that I have a web browser.
Comment 9 Jake Gage 2006-09-12 02:50:48 EDT
The user in question still can add Web calendars, but no data displays for any
of the iCal calendars in question.  The command line output is the same:

(~){dispader}01:49am] evolution --component=calendar
CalDAV Eplugin starting up ...
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files
calendar-gui-Message: Check if default client matches
(1158043623.2786.0@dispader 1158043623.2786.0@dispader)

Any ideas?
Comment 10 Jake Gage 2006-09-12 02:52:25 EDT
Nice new look, though.
Comment 11 Jake Gage 2006-09-12 18:31:13 EDT
All right.  Can anybody at least help me out with instructions on how to reset a
users evolution calendar data?  Removing everything in the user tree that
references "*volution*" in either file or contents doesn't seem to help.
Comment 12 Matěj Cepl 2007-08-31 11:21:16 EDT
The distribution against which this bug was reported is no longer supported,
could you please reproduce this with the updated version of the currently
supported distribution (Fedora Core 6, or Fedora 7, or Rawhide)? If this issue
turns out to still be reproducible, please let us know in this bug report.  If
after a month's time we have not heard back from you, we will have to close this
bug as INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 13 Matthew Barnes 2007-10-02 13:53:04 EDT
Closing as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.